Most Packages fail to install



  • Snapshot: 2.0-BETA4 (i386)
    built on Fri Aug 27 09:04:09 EDT 2010
    FreeBSD 8.1-RELEASE

    I made a fresh FUll-Iso-Install on a CF with embedded kernel on an alix-board. With older Snapshots most things worked fine, but now i am unable to install Packages like squid, squidguard, freeradius
    or OpenVPN…. The Install ends, after downloading the files (i found them in /tmp) with this message:

    "Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies... done.
    Checking for successful package installation... of p7zip-9.04 failed!

    Installation aborted."

    Packages like "Blink LED" or "BandwidthD" install without problem.
    I repeated all this with another "fresh" install -> same result.
    Is it a new bug?

    Cheers,
    Sascha



  • Remember with beta 2 not all the packages are ready to go yet…. so your mileage my very!



  • Most work, some don't. If you want you can post a list of packages that do not work to help jump start the process for package authors.



  • Solved!
    I spent the whole weekend trying out everything - 6 new CF-installs, freebsd-crash-course ;) … no success!
    Past Midnight, i was near giving up, every single package installed perfectly. What happend?
    Finally i found the problem: We have a 3 Mbit-satellite-connection with 700ms-PING and heavy throtteling, so most of the time we only get 64 kbit/s. But we have a Freezone from Midnight until 6.00 am, where Bandwith and download-volume is not limited. The reason why the installation was only succussful after midnight, was definitely the slow internet-connection during the day. Although the package download completed (slow, but complete!) the final install-check failed because of the slow connection. I don´t know how this could be, but i am sure, that this was the reason.
    Have a nice week, greetings from  the the ecovillage of sieben linden,

    Sascha

    p.s.: now i have squid/squidguard and freeradius running well on 2.0 on an alix-board with 8gb SLC-CF-Card. I will see how long the CF-Card will run, some experts told me, the new CF-slc-cards should run for many years. Backup, wait and see :)


Log in to reply