Changing interface IP address makes interface non-functional



  • 2.0-BETA4  (i386)
    built on Mon Aug 30 04:13:38 EDT 2010
    FreeBSD 8.1-RELEASE

    You are on the latest version.
    Platform nanobsd (2g)

    1. Create and enable interfaces for LAN and OPT1-11 with static IP addresses
    2. Create mlppp bundle from OPT4-10
    3. Create dynamic gateways for OPT4-11 for accessing modems
    4. Change the IP address of OPT5, save and apply

    At this point OPT5 will drop from the mlppp bundle. System log looks like this (newest at top):

    
    Aug 30 17:01:39 	ppp: [wan_link1] Link: reconnection attempt 42 in 3 seconds
    Aug 30 17:01:39 	ppp: [wan_link1] LCP: Down event
    Aug 30 17:01:39 	ppp: [wan_link1] Link: DOWN event
    Aug 30 17:01:39 	ppp: [wan_link1] can't remove hook mpd7556-1 from node "[26]:": No such file or directory
    Aug 30 17:01:39 	ppp: [wan_link1] PPPoE: can't connect "[26]:"->"mpd7556-1" and "[57]:"->"left": No such file or directory
    Aug 30 17:01:39 	ppp: [wan_link1] Link: reconnection attempt 41
    Aug 30 17:01:37 	ppp: [wan_link1] Link: reconnection attempt 41 in 2 seconds
    Aug 30 17:01:37 	ppp: [wan_link1] LCP: Down event
    Aug 30 17:01:37 	ppp: [wan_link1] Link: DOWN event
    Aug 30 17:01:37 	ppp: [wan_link1] can't remove hook mpd7556-1 from node "[26]:": No such file or directory
    Aug 30 17:01:37 	ppp: [wan_link1] PPPoE: can't connect "[26]:"->"mpd7556-1" and "[57]:"->"left": No such file or directory
    Aug 30 17:01:37 	ppp: [wan_link1] Link: reconnection attempt 40
    Aug 30 17:01:33 	ppp: [wan_link1] Link: reconnection attempt 40 in 4 seconds
    
    

    Satus: Interfaces looks like this for OPT5:

    
    MODEM3 interface (vr0_vlan203)
    Status 	down
    
    

    The console looks like this:

    
    MODEM1 (opt3)             -> vr0_vlan201 -> 192.168.201.101 
      MODEM2 (opt4)             -> vr0_vlan202 -> 192.168.202.101 
      MODEM3 (opt5)             -> vr0_vlan203 -> NONE 
      MODEM4 (opt6)             -> vr0_vlan204 -> 192.168.204.101
    
    

    Option 2 on the console appears to complete normally but when the console status page reloads there is still no IP address for OPT5.

    
    # ifconfig vr0_vlan203
    ifconfig: interface vr0_vlan203 does not exist
    
    

    Hitting the Save button on interfaces_vlan_edit.php for the vlan in question does not bring up the interface. Neither does the Save button on interfaces_assign.php. The only way I've found to bring up OPT5 again is to reboot.

    Is there any way to make it so one can change the IP address of an interface without a reboot?


Log in to reply