PfSense 1.2.3 WAN force Full Duplex



  • I have read through the forums… visited the doc.pfsense.org... and bugged a couple of well-knowns around here. I can not use Auto Negotiate on my WAN connection it will always default to half-duplex. I have modified the configuration located at /cf/conf/config.xml to include the option for full-duplex and specified the media type. At this time on version 1.2.3 the option does not seem to take at all.

    Below is a copy/paste of my config... does anyone notice anything obviously wrong with my config?

    I am using TRENDnet Gigabit PCI Adapter Cards (TEG-PCITXR)

    <wan><if>re0</if>
                            <mtu><blockpriv><blockbogons><media>10baseT/UTP</media>
                            <mediaopt>full-duplex</mediaopt>
                            <bandwidth>10</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                            <spoofmac><disableftpproxy><ipaddr>192.168.1.2</ipaddr>
                            <subnet>30</subnet>
                            <gateway>192.168.1.1</gateway></disableftpproxy></spoofmac></blockbogons></blockpriv></mtu></wan>

    P.S. I am not using the private ips on my device. I placed them there instead of my public ips.

    Thanks in advance for your assistance.
    -james



  • Question: why is this a problem?  I mean that it seems to auto-neg half-duplex?  Unless you have a 100mb WAN connection, full-duplex is not going to be any faster than half-duplex.  I also get very leery when I see people forcing speed and/or duplex, since it is hard to be sure what the other peer is doing, and you can cause major issues if you get it wrong.



  • We are running VoIP behind it… any information on the forced full-duplex?



  • What does VOIP have to do with anything?  Ethernet duplex&speed is a layer-2 issue.  Keep in mind that if auto-neg fails, the requirement is that both sides fall back to 100/half, so unless you are forcing both sides to 100/full you are setting yourself up for trouble.



  • My ISP requires that I set the WAN interface to 10/Full. The media converter from my fiber provider does not accept "auto-negotiate". I need to be able to specify 10/Full.

    Yet again I ask… Can anyone offer a suggestion as to why my configuration (posted above) is not working?



  • Not to get off-topic…. however you brought it up... Not only do I have to specify Full-Duplex at my 'office' I also need to specify Full-Duplex at both Internap hosting facilities I house servers in. I have to specify Full-Duplex at the Internap hosting facilities a couple of my clients host servers in... this is not unheard of and quite common so I am confused as to the debate regarding duplex modes. I really just want to know if pfSense is going to offer me a viable solution or if I need to keep looking. I understand how to ask 'good questions' I know who ESR is and why he wrote that document in the first place. I came here for help, not further frustration. If you do not know the answer that is cool... perhaps someone else does.

    Thanks in advance to any who can offer some insight as to the reason behind my configuration not working.

    -james



  • Sorry, I meant to say '10/full', not '100/full'.  Look, we don't know anything about your level of technical knowledge, and it is common for people to come here asking for the answer to the wrong question.  It would have been nice to know that you had a requirement to set the option to 10/full due to broken hardware on your fiber converter.  That said, sorry, I don't know why it would not take.



  • I used to work with an ISP with all kinds of network hardware (including various cisco), so yes, I understand exactly the hoops you have been forced to jump through.  That said, don't confuse technical requirements with policy requirements - I have had the same experience (with a major backbone provider) where they set all their switch ports to 100/full, requiring the customers to do the same.



  • I don't have a lot of time to look at this (until this afternoon.)  Looking at the code real quick, a suggestion: remove the mediaopt setting and change the media setting to '10full'.



  • Thank you Dan I will give that a shot.


  • Rebel Alliance Developer Netgate

    Also, check the output of "ifconfig -m" on your WAN interface to make sure 10baseT/UTP is a supported media specification for that ethernet card. (It should be, but it's worth double checking)


Log in to reply