Can't route PPTP



  • @grazman:

    @grazman:

    Does anyone have PPTP working on a 2.0 install dated in the last month or so?

    After updating the snapshot to yesterday's build it will work only if I put the proxy arp of the pptp server in as a workaround.

    I also have problems with this. Client is trying to connect PPTP server outside. It seems that they are able to begin negotiating the VPN tunnel, but GRE-packets aren't routed through.

    We have NAT disabled. LAN - to internet everything is allowed. Also tried with specific rules allowing GRE to Internet and TCP 1723 to internet. No success. Clients get public IPs.  PPTP server is off.

    We have tried with multiple builds from late May to Aug 12th on ALIX platform.

    Any ideas?



  • This has nothing to do with the thread you hijacked so I split it.

    Get a packet capture on the inside and outside interfaces, see what's happening. When there is no NAT involved, there are no GRE difficulties, you simply have to allow it in your inside interface's rules.


Log in to reply