Making read only the default file system.



  • Hi all,
      I've installed pfsense via the Cdrom onto a flash device.  Everything works great, but I still see a lot of writes happening to my flash drive even though I have connected to a syslog server for writing the logs.  Is there an option via the web interface I can tick to make the default mode read only?  If there's no way to do it via the web, is the a shell command?

    Thanks,

    Todd



  • Install the NanoBSD version.
    This is the version intended for such installs.



  • Thanks.  I had initially not used the nanobsd because it doesn't have video output.  Is it possible to enable the video out via VGA?  I've also tried to install the 2 GB flash using dd

    
    sudo dd if=pfSense-1.2.3-2g-20091207-1914-nanobsd.img of=/dev/sde bs=16k
    
    

    However when I attempt to mount the drive I receive errors that the superblock is corrupt.  Which image should I use?

    Thanks,
    Todd



  • Are you attempting to mount it under FreeBSD?



  • I've tried Ubuntu 10 and the physical machine we run our router on.  Ubuntu can't read it, while it can read the drive installed from the CD.  The router never loads the bootloader, I don't get the VGA output before the serial redirect.



  • You'll have to tell Ubuntu that you're trying to mount a UFS2 file system, otherwise it won't know.  It may also be that Ubuntu doesn't know the UFS2 filesystem format, the man page is unclear.  The CD is a standard ISO9660 file system, which is why it can read it.



  • I'm actually talking about the USB stick AFTER I've used the CD to install the operating system to it.  Ubuntu can read the UFS partitions from the USB stick after the live cd installer has partitioned and installed the OS.  However, this doesn't resolve my issue of the physical router we're using not booting nano bsd from the usb drive, but it will boot the Live CD installation from the USB stick.  Any ideas why this is happening?  I see 3 partitions on my device after I flash it with the image.  The first partition is bootable, the 2nd one is not, and the 3rd is UFS.  I'm assuming the first one is failsafe firmware, and the next partition is for in place upgrades and the 3rd is for configuration data.  I know the USB media itself is not an issue since I can boot from it after using the Live CD to install to it.  Any ideas why I can't boot using the image and dd to write the image to the usb?



  • Hey guys,
     I've made it a bit further this time, but I'm still having issues.  I have 2 questions.

    Can I use a serial to USB cable as a null termination cable?  None of our laptops have serial in them, so I have been using one with USB that creates a com port 17.  However, when I try to connect realterm to it on COM17 and 9600, I never get any data.

    When I boot, this is the last thing I see on the VGA display.  I never get the "/" the documentation refers to.  Is my image not booting properly?

    http://webimages.s3.amazonaws.com/img_0269.jpg

    Thanks,
    Todd


  • Rebel Alliance Developer Netgate

    That image is normal, that's what I see on my VMware NanoBSD instances on their consoles.

    USB serial on the client side should work. Just make sure you're using a null modem cable, and set for 9600/8/n/1.



  • All up and running guys.  Thanks for the help.  Out of curiosity, why do we need a null modem cable?

    We do programming on embedded hardware, and we use straight serial for terminal input and output.  Is this part of the BSD kernel or was it purposefully written to require the null modem cable?

    Apologies in advance if that's a glaring obvious question.

    Thanks,
    Todd



  • It's a feature of the RS-232 serial connector, if both ends have the exact same connector and pin configuration the wires  have to switched around to get it to work.


Log in to reply