Freeswitch package on 1.2.3 broken?



  • I've tried with a few different installs on different machines now, and it seems that the freeswitch package "successfully" installs via webGUI, but the actual working directory (/usr/local/freeswitch) never gets created. The rc scripts, configs and web interface pieces are all installed just fine however, but no binaries to be found on the machine.



  • Oops. Nevermind. Although the docs say that 1.2.3 is required for the Freeswitch package, only freeswitch-dev installs and runs cleanly.



  • A week ago I installed the non dev version without issues and it worked fine.  I then decided to try the fusionpbx gui, following the instructions without issue.  I decided to go back to freeswitch package and now I am experiancing what you described, it says installed but the directories /usr/local/freeswitch not created.  Just for the heck of it I wiped the machine clean, reinstalled pfsense and tried freeswich again, still no luck.

    Not sure what happen, I had no issues a few months ago when I install the package and then a week ago, now I cannot get it installed.



  • @minus:

    Oops. Nevermind. Although the docs say that 1.2.3 is required for the Freeswitch package, only freeswitch-dev installs and runs cleanly.

    I installed both version seperately but only the freeswitch-dev installs without problems but when I go to the status page I still get the errors above. Will check it tonight if the directory contains anything.



  • Hello

    I was having the same issues. I looked at the installation rutine and discovered that the FreeSwitch core files are hosted on an expired domain. portableusbapps.com expired on Aug 16th. I have sent Mark an email to let him know but have yet to hear back. I think he is busy getting ready for the course on FreeSwitch he is giving. The FreeSwitch-dev files must be hosted elsware.



  • Idd the dev files are the ones working. Everythings fine now.


Log in to reply