Removing packages that don't want.



  • I've installed the "opnevpn client export" package but after the last firmwareupdate (2.0-BETA4 (i386) built on Mon Sep 6 23:08:35 EDT 2010) that tried to remove it without success, the client export won't show in OpenVPN page, the package won't show in the available packages, and I can't remove it from installed packages while deinstallation hang on "Loading package instructions… Deinstall commands..."
    Can I remove it from shell? I tried to do so, but it won't show up with pkg_info (pkg_info: no packages installed)


  • Rebel Alliance Developer Netgate

    If it's that stuck, you may have to edit its entry out from inside <installedpackages>in the config file itself. (Download a backup, edit it out, restore the backup)</installedpackages>



  • Problem solved thanks to your response.  ;D
    But did I something wrong (waited to less… about a quarter for deinstall)? Can it be there's a problem with some browser (in my case, Safari on Mac OS X)?

    P.S. After re-installing "Openvpn clinet export" package, that seems to work as it should, if I ask pkg_info from shell I can't see "Openvpn clinet export" in the installed packages, there are only p7zip-9.04 and zip-3.0 (both dependency from "Openvpn clinet export)


  • Rebel Alliance Developer Netgate

    It should only take a few seconds for most packages to uninstall. I installed and then immediately uninstalled the openvpn client export package and it did both for me without error. Not sure what could have gone wrong in your case.


Log in to reply