OpenVPN client export utility



  • Hi all,

    Have been running PfSense 2.0 Beta for over 5 months now and it's been seemless performing load balancing, dual wan, and multi IPsec connections. I have decided to now setup OpenVPN bug have hit a roadblock. I can't install the client export utility! The error it reports is:

    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies... done.
    Checking for successful package installation... of p7zip-9.04 failed!
    
    Installation aborted.
    

    I searched this forum for that error and it seems some people have had it, but for different reasons..
    I checked known issues and the package status and it's not listed in either.

    Also even though it fails, it still appears in the Installed Packages area, and needs to be removed.

    Current build info:
    2.0-BETA4  (i386)
    built on Wed Sep 1 11:07:08 EDT 2010

    I was running BETA1 until i hit this problem, and decided to update to see if it would resolve, but to no avail.
    The OpenVPN Client Export package version i was trying was 0.3, but i noticed it has been updated to 0.4. Neither have worked.

    Are there any other logs i can check the see what is happening? If i can't get to utility installed, can i export manually??

    Any help would be appreciated. Let me know if you need any more info.

    Thanks



  • packages install goes well under this build for me

    2.0-BETA4  (i386) built on Sun Sep 5 08:52:01 EDT 2010



  • Has anyone tried to install this on 2.0-BETA4 (amd64)?  I get the same error as the first OP.  Same symptoms - the package is listed as installed, but it isn't.  How do I clear this?

    Thanks,
    Elliot



  • @mikesamo:

    packages install goes well under this build for me

    2.0-BETA4  (i386) built on Sun Sep 5 08:52:01 EDT 2010

    Did you have any issues with previous builds?


  • Rebel Alliance Developer Netgate

    I fixed the package over the weekend, it was pointing to the wrong version of p7zip. The build date shouldn't really matter.



  • Hi Jimp

    Still getting the same error. It still says p7zip-9.04. Can i install it manually maybe?


  • Rebel Alliance Developer Netgate

    For i386, the p7zip 9.04 version is there.

    > ls -l *p7*
    -rw-rw-r--  1 packages  packagewr  1762952 Feb  3  2010 p7zip-9.04.tbz
    -rw-r--r--  1 packages  packagewr  1806240 Sep  8 02:11 p7zip-9.13.tbz
    

    It was amd64 that wasn't finding the right version (which I fixed)

    Though I do see now that 9.13 has built for i386. I'll update the i386 package too. Give it a try in about 10 minutes.



  • Still no luck im afraid  :(

    Checking for successful package installation... of p7zip-9.13 failed!
    

  • Rebel Alliance Developer Netgate

    I just tried it on my home router (i386) and it worked fine.

    What other packages do you have installed? What shows up if you run "pkg_info" from the shell or Diagnostics > Command?



  • No other packages are installed.
    I ran pkg_info and it returned: no packages installed.
    I attempted to install the export utility again, and even though it failed it was still listed under Installed Packages. However, running pkg_info still returns no packages installed.  ???

    What about manually installed p7zip? Could i copy it via SCP and run a command in the shell to install it? It seems its the p7zip thats causing the problem, not the export utility itself.


  • Rebel Alliance Developer Netgate

    That is normal, pkg_info will only show "FreeBSD style" packages, and not pfSense packages.

    Try this:

    pkg_add -r http://files.pfsense.org/packages/8/All/p7zip-9.13.tbz
    


  • Great, i think thats done it.

    I ran that command, attempted to reinstall the export utility and it failed on zip-3.0.

    I then ran:

    pkg_add -r http://files.pfsense.org/packages/8/All/zip-3.0.tbz
    

    Once it was downloaded i went to Installed Packages, reinstalled both XML and GUI components and it is now appearing under OpenVPN.

    Thanks for your help jimp  :)



  • Hi folks,
    using the Sep. 24th Build BETA4.

    installed the client-export package.

    the GUI menu is there, but I can't seem to be able to generate the installers.
    I'm selecting the server, but there is not "save" button or anything similar. what am I missing?

    Thanks, Uri


  • Rebel Alliance Developer Netgate

    In order to get installers you need one of the following:

    1. A remote access "user auth" setup that does not use ssl/tls - which exports a general installer that just prompts for a password on connect. (e.g. auth against RADIUS or LDAP only)

    or

    1. A remote access "SSL/TLS" setup that has local users defined which have user certificates from the same CA as the remote access OpenVPN server instance.

    or

    1. A remote access "SSL/TLS + User Auth" setup against the local user database, which has local users defined which have user certificates from the same CA as the remote access OpenVPN server instance.

    Most likely issue is that you have not yet made any user certificates, or these user certificates are not from the same CA as the OpenVPN server.

    A remote access "SSL/TLS + User Auth" setup against a remote auth method (RADIUS or LDAP) will not be manageable through the exporter since there is no way to know what users are valid on the auth server in order to define them or make certs. You could make certs manually in the GUI and alter their config and such to take them, but it would not be automatic.



  • 10x for the quick reply.
    that was it..


Log in to reply