Squid - empty access.log



  • Hi guys,

    I searched the forum but didn't find a solution (or a similar problem), sorry if this has already been answered.

    So basically my problem is that Squid always leaves the access.log file blank. >:(
    The configuration specifies /var/squid/log as log directory and "enable logging is checked".
    The permissions are the same as for cache.log (that is being written correctly) and I can't find a Squid error message in the logs.

    So does anyone have an idea?
    Also, is there a specific error log file for Squid, or is it just supposed to be /var/log/system.log?

    It's been this way for a while and now people are asking me to fix it (I should have expected this would happen at some point), so any help is much welcome!
    Thanks! ;D


  • Rebel Alliance Developer Netgate

    The most common way that can happen is if no traffic is actually passing through squid. :)

    Are you sure the proxy is actually being used?



  • Well I tested some urls from the blacklist to make sure the proxy works, and the cache.log files seem to grow up (I'm not sure it's a sign the traffic is going through Squid).



  • Up please!!

    Really no idea?


  • Rebel Alliance Developer Netgate

    Did you check the box to enable logging on the main squid config page?



  • Yes I did!



  • Hi,

    i've got a quite similar problem, when i check the "enable logging" box i can't access to internet anymore.
    i've tried to enable access_log by editing manually squid.conf but without results.
    any suggestions would be really appreciated



  • Sorry, I still have no solution.

    My problem seems a bit different though, as the box is checked and I have no problem getting to the Internet.
    But I haven't tried to edit the config file, which one is it?


Log in to reply