Mini-ITX LogicSupply PFSense 2.0 Install



  • Hi Guys.

    I'm not being successful at all with this install.

    MB: Jetway NF96FL Dual Core Atom D510-Fanless w/ 2GB DDR2 RAM - 4x Gb LAN Ports - AD3RTLANG

    Trying to install - pfSense-2.0-BETA4-20100910-0431.iso.gz - No Joy!

    Trying to install -    pfSense-2.0-BETA4-4g-20100910-0611-nanobsd.img.gz - No Joy!

    Details for image install:

    I downloaded "physdiskwrite+PhysGUI" to windows system and unzipped img file in the same folder.  Hard disk is a 2.5 Sata Drive which was attached via USB adapter and because Ich spreche nicht Deutsches, I had to guess my way thru the process, but from all indications, the image transferred.

    After Booting and flashing cursor, I get this - "BTX loader 1.00  BTX Version is 1.02"

    No Joy. Any ideas?

    Details for iso install:

    I am using an external USB CD/DVD Drive. It is a Samsung TruDirect External DVD Writer Model SE-T084.
    Upon booting and making the selection for install, any, I get the following error..

    "If you have invalid mount options, reboot, and first try the following from the loader prompt:
          set vfs.root.mountfrom.options=rw
    and then remove invalid mount options from /etc/fstab.

    Loader variables:
    vfs.root.mountfrom=cd9660:/dev/iso9660/pfsense
    vfs.root.mountfrom.options=rw

    Manual root filesystem specification:
        <fstype>:<device>Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                                      eg. cd9660:/dev/acd0
                                      This is equivalent to: mount -t cd9660 /dev/acd0 /

    ?                        List valid disk boot devices
    <empty line="">Abort manual input

    mountroot> cd0 at umass-sim0 bus 0 scbus 0 target 0 lun 0
    cd0: <tsstcorp cddvdw="" se-t084m="" td01="" removable="" cd-rom="" scsi-0="" device="" …etc,="" etc"<br="">Any idea's why this would happen?

    Thanks for your help.

    Jits</tsstcorp></empty></fstype></device></device></fstype>



  • Re the nanobsd image install: Soon after startup the nanobsd OS switches to the serial console, hence there is no further output on the video port. This is discussed fairly often in the forums.

    Re the ISO install: It looks as if the CD might have gone offline between the time of boot and the time the startup was trying to mount root or the system hadn't yet scanned enough of the device tree to see the CD drive. So repeat the boot and at the mountroot prompt type: cd9660:/dev/iso9660/pfsense (that is, repeat the attempt the system had made to mount the root file system.) The loader variable vfs.root.mountfrom gives the location the OS startup is looking in to find where to mount the root file system.



  • Hi.

    I still cannot install pfsense 2.0 beta4-recent on the the above itx board. The same above error is present even when the variables are set at the boot prompt.

    PFsense 1.2.3, boots and installs fine though. No problems there, so if that can happen, why not for 2.0?

    Thanks.



  • For embedded installs, the output is redirected to serial console, you can make the configuration changes needed by using another computer with a serial port set to 9600/8/N/1 and hook it up to the pfsense box via a NULL modem cable.  Use Terminal or Putty for the access.

    Certain changes in FreeBSD 8.x (the based for pf 2.0) resulted in the system booting before USB devices were mounted properly.

    I've made a short thread on a workaround here:  http://forum.pfsense.org/index.php/topic,28707.0.html

    You'll need to do the same for the USB CDROM on the first boot to install.
    Some people can get by without it because the USB mounts fast enough or the system doesn't load pfsense fast enough to time out on the USB mount.

    Also, I've encountered this problem with a slow/ faulty optical drive and also with a faulty CD-R.  Verify that your CD-R/ DVD-R media is written properly.  Try burning another copy of the disc or try another optical drive (if possible).



  • Hi,

    Thanks for the tip. Remember, I am doing a full install.

    I tried your tip along with set vfs.root.mountfrom.options=rw

    Neither worked, well, what I should say is that the system hung for well over 15 minutes.

    I'll try a normal cd-rom instead and see what the results are.

    thanks for your help. Jits.



  • Well, well, well…this has been two weeks from hell as far as what lightning can do.

    The board has another sata port and finally, PFsense 2.0 got installed. Yeeehaw!

    I simply can't wait...to see what else goes wrong now.

    Jits.


Log in to reply