PfSense install on an HP t5740 Thin Client



  • I figured I’d share my experience in case anyone was looking to do the same thing…

    The unit I purchased has 2GB of memory and a 4GB IDE Flash drive. Install did not go smooth at all, but was not hard to get going with a little help of the pfSense dev team. (thanks again Chris and Jim!)

    I started off trying to get pfSense 2.0 BETA4 embedded working, but there is a bug in nanoBSD that causes the CPU to max out consistently. It looked like something with the USB at first, but when I disabled all USB devices the IDE driver looked like it took its place with using 100% of the CPU. pfSense 2.0 with FreeBSD 8 worked fine, but snort was causing issues when it was installed. At this point, I already wasted more time than I wanted to spend on this project so just installed 1.2.3 and everything has been fine ever since. If one of the dev guys would like to use my system to work out the snort bugs, I can give you https/ssh access. Obviously, with the flash drive I’d prefer to run the embedded version but the current setup will do for now.

    Before I even got to this point, I had to figure out how to get a USB CD-ROM to boot. I also had this same issue trying to boot pfSense nanoBSD that was installed on a USB stick. I didn’t test it, but I’m sure this will work for that as well. To boot off USB CD-ROM, go into the loader prompt at the first boot menu and type:

    set kern.cam.boot_delay=15000

    boot

    Probably 1 in 10 times, this didn’t work for me. If this happens to you, just reboot and start over. It always worked the next time.
    At this point, you can install from the LiveCD like you normally would.

    If you want to install the embedded version, be aware that you will need a male-to-male 44-pin IDE adapter to connect the flash drive to a standard 44-pin IDE cable if you’re planning on pulling the drive out and flashing it with another machine. The unit also does have an internal SATA connecter, but it uses a reversed plug as well and you can’t boot off of it. (at least I couldn’t)  I ended up having to boot off the LiveCD and using the shell to download the nanoBSD version to the flash drive. This worked perfectly, with the exception of Snort not working correctly.

    To download the embedded version to the flash drive, type this in the shell (replace the build number with the current one):

    fetch -o - http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/nanobsd/pfSense-2.0-BETA4-4g-20100831-0703-nanobsd.img.gz | gzip -dc | dd of=/dev/ad6 obs=64k

    reboot

    After downloading the image to drive and rebooting, you’ll need to boot off the LiveCD once more and run this command:

    boot0cfg -v -B ad6

    Reboot and you should be good to go. This last command is only needed for the embedded version. Installing the full version of pfSense (both 1.2.3 and 2.0) installed the typical way once you get the CD to boot.

    Since the t5740 only has 1 Broadcom nic, which pfSense 1.2.3 does NOT recognize (2.0 see’s it fine), you’ll need to buy the PCIe expansion module.  
    This is the one you’ll need:

    http://h10010.www1.hp.com/wwpc/ie/en/sm/WF06c/A1-329290-329229-346585-346585-4093452-4080482.html

    I also purchased a PCIe 4x Intel dual gigabit network adapter with the initial plan to have 3 interfaces (WAN/LAN/OPT). Since the Broadcom nic isn’t recognized, I just ended up using both intel nic’s as WAN/LAN. I wasn’t planning on using the third interface right now anyway so it wasn’t a big issue for me. I also tried several wireless N USB adapters and although most where on the FreeBSD 8 hardware list and did show up as being installed, they did not work correctly.

    The t5740 has been up for a few weeks now without issue. I figured I’d give 2.0 another try when the next version of snort comes out. Maybe Jamesdean is still working on compatibility issues with 2.0? Overall, I’m happy with the end result and performance is where I expected it to be. My connection is 20mbps/3mbps cable connection and it seems like my cpu usage is a 1:1 ratio with my bandwidth. (7% CPU usage = 7mbps download). I only have one IPSEC VPN, going to my work’s datacenter so not much going on other than downloading.

    I attached a picture of my home network so you can get an idea of what the finished product looks like, I didn’t get a chance to take any pictures of the t5740 before installing it (didn’t think about it until after) To get an idea of its size, the switch below it is an 8-port Dell managed switch. Don’t remember the model number and the cabinet is closed up now so it’s not so easy to check (flush mounted panel is screwed in).

    I think I covered everything, I hope this info is helpful to anyone trying to get pfSense to work with an HP thin client.



  • See you PM.

    James



  • For JamesDean,

    I send i private message any news?

    sndrino


Log in to reply