Unable to install pfsense 1.2.3 on an ibm x225



  • hi guys,

    i hope you can help me with this problem :)
    i'm trying to install pfsense 1.2.3 on an ibm x225 with 2x 36gb disk in raid1 with a ibm serveraid controller.

    when i start the server, it boots from cdrom and stop on recognizing hard drive… it stop exactly when recognize acd0(at btx loader)

    then i try to remove ibm serveraid and boot with lsi logic controller integrated on mainboard with raid1 again....same result......

    finally i decide to boot without any array configured and see what happen. wow it boots perfect and i see also that it loads the driver for both controller without(indeed) finding any array....

    pls someone can advice any solution which let me install pfsense onto this servers?

    Thanks so much
    Giulio



  • some updates….

    i have tried many setup(bios , controller bios..) but finally i have discovered a thing. if i create a raid 1 with ibm serveraid and pull out one disk pfsense livecd boot correctly it detect the controller and logical disk and when i press 99 to do installation it install perfect, but when i reboot it can't find OS!!!  i tried to reinsert the disk i have pulled out before and it boots with this:

    freebsd

    boot: f1

    then i press f1 and it reply with ############# and won't boot (sigh).

    i think that ibm serveraid 6i use the lsi logic controller bus (not fully supported) for manage all the disks, infact if i pull out serveraid and boot with integrated lsi controller with raid feature or without, live cd stops at btx loader, but only if some disks are attached!!!!

    finally to solve my problem i have installed an adaptec 29160 connect the sca disks and i was able to install pfsense properly using gmirror raid.

    but it is strange that in the hcl there are drivers for both ibm serveraid 6i and lsi logic controller, but they can't manage the hardware in the right way.

    thanks a lot for any comment would come
    Giulio



  • Same problem here, a x226 with Serveraid 6i and 3 hd 36gb (raid 5), there's no way to boot from the live cd…

    Do you have any update?

    Thanks


  • Rebel Alliance Developer Netgate

    You might try a 2.0 snapshot. If the CD has issues, try the memstick image and boot from USB.


Log in to reply