Problems with "System: Gateways: Edit gateway" on snap Fri Sep 17 02:02:42



  • On snap Fri Sep 17 02:02:42,
    When I go to "System: Gateways", both my gateways, WAN & OPT1 are listed as "default".
    If I try to edit OPT1 (or wan) to unlist it from being default the web-gui crash.

    Also when I try to edit a static route "System: Static Routes: Edit route" and set a /29 range true OPT1 I get the error: "A valid gateway must be specified."



  • I'm on the same snap Fri Sep 17 02:02:42…

    I also noticed today when I tried to add a static route to my WAN interface, I received the same "A valid gateway must be specified." error.

    I've ALSO been having WebConfigurator crashing and generally running slow when doing anything with gateways.

    I will note however that with this snap, multi-WAN is once again functioning... But it would appear that other gateway related issues have popped up now.



  • Yeah for dynamic gateways used on static routes there might need a resaving them all.



  • I have updated to build Fri Sep 17 14:32:23.
    I still can't create a static route to a dynamic GW or to a static GW.
    I triad to remove traces of the old route and recreate it but I get the same error.

    The thing with the default GW still exist and both interfaces are set as default.
    When I try to unselect OPT1 from being default the web-GUI does not crash but it also don't do nothing.

    Hope this will help.



  • I had that problem, I ended up doing a clean reload then restoring the config file, selecting only one gateway (I didn't have any selected prior) then running "playback gitsync master" from the developer shell, rebooted then the problem hasn't reoccured. but I admit I'm afraid to mess with it too much now.



  • Seem  that static gateway is broken…

    I have setup a new and simple WAN and LAN setup and can't add a static route on the LAN iface: "A valid gateway must be specified".

    Very embarrassing  :-\



  • My system is working fine.

    I did not try to change any thing in the settings. Just updated to the latest snap. (Fri Sep 24 13:27:59 EDT 2010).
    Also at the moment all my interfaces, including the WAN one's are setup as static, No DHCP, as I feel it's much more stable this way.

    My next trials are going to be changing my WAN from static connected to a NAT router to directly doing PPPoE with a ADSL modem.



  • There are several bug tickets issued in the last week for Gateways related issues. I'm working on resolving them.

    GB



  • PM me with your email address if you want to test changes in advance of them being committed to the repository.
    Thanks,
    GB


Log in to reply