Squidguard - unable to reinstall



  • So I noticed a new squid available.  No idea what the changes are (no change file anywhere) but was tempted to install it.
    So I did, and then the next step is to reinstall squidguard to get the setting back up.  Normally this is no issue.
      Today I did that, but I have been unable to install squidguard as well.  If I do a reinstall (either one) or a delete package and reinstall I get..
    Loading package instructions… Auxiliary files... done.
    Deinstall commands...

    And then it sits there on the gui.
    I've tried uninstalling squid, rebooting, and even going to terminal and issuing a pkg_add -r http://.....squidguard.... 
    Manuall install seems to work, but no gui is available.

    I've tried searching and can't find anything.
    Anyone come across this?
    Any way to get it manually off the list, and force a reinstall?

    thanks!



  • So I tried one more thing and it worked.  I did a search and found where other packages kept their info..
    I went to the shell and deleted squidguard.xml  (rm squidguard.xml)  in the //usr/local/pkg directory.
    after it was deleted, I could delete the package via the gui and then reinstall it.

    Hopefully this will help someone in the future (maybe even me!)  :)



  • I had the same issue, did what OP suggested. This fixed it for me also.



  • It also seems that if you deinstalled squid first then deinstalled squidguard, that issue may occur. Leaving squid last to deinstall seems to work fine.


Locked