IGMP working but noisy



  • G'Day,

    I've been using the more recent pfsense..

    Current version: 2.0-BETA4 Built On: Thu Sep 16 12:44:52 EDT 2010 for i386

    and previous iterations and I'd like to log a request for the IGMP proxy.

    While it all works nicely the IGMP proxy logs to the system log and is very noisy. I get up to 5 entries per second thus…

    Sep 21 14:13:45 igmpproxy: Note: RECV Membership query from 172.20.1.1 to 224.0.0.251 (ip_hl 24, data 8)
    Sep 21 14:13:45 igmpproxy: Note: RECV Membership query from 172.20.1.1 to 224.0.0.1 (ip_hl 24, data 12)
    Sep 21 14:13:46 igmpproxy: Note: RECV V2 member report from 172.20.1.30 to 224.0.0.251 (ip_hl 24, data 8)
    Sep 21 14:13:46 igmpproxy: Note: RECV V3 member report from x.x.x.x to 224.0.0.22 (ip_hl 24, data 16)
    Sep 21 14:13:46 igmpproxy: Warn: unknown Mode in V3 report (673189920)
    Sep 21 14:13:46 igmpproxy: Note: RECV V2 member report from x.x.x.x to 224.0.0.251 (ip_hl 24, data 8)
    Sep 21 14:13:46 igmpproxy: Note: The IGMP message was from myself. Ignoring.

    While these messages are normal, they clutter the system log making it unusable.

    I propose that either a log level switch be added to the IGMP proxy or it should get its own log and associated tab under system logs so that the "system" log once again only shows meaningful entries.

    thanks

    Tim



  • I second that.
    I've started to only enable the proxy manually only when i just need it to keep my log readable.



  • push

    The systemlog is unusable if igmpproxy is enabled… please move igmp logs to a new tab/log!

    Edit by GruensFroeschli: adding more pushes the the thread wont help.
    You can make a feature request on: http://redmine.pfsense.org


Log in to reply