Verizon Fios With 5 IPs



  • I've recently had fios business class installed.  I've got traffic going in an out now on the first ip address in the block they assigned me.  I'm using that address for the WAN IP.  I've gotten PPTP successfully setup.  I added the rest of the IPs under Virtual IPs and tried creating a port forward nat from one of the VIPs to an internal server on port 80.  I had the firewall auto-generate the rule to allow traffic to this server.  Short version is that it's not working.  Does anyone have any experience with setting up fios with VIPs?



  • Is your subnet mask on the WAN set to /30?  It needs to be something larger than /32 (1 IP) if you intend to utilize the additional IPs.



  • Are you refering to the VIPs subnet?  The subnet from Verizon is /24



  • No, on the WAN interface settings.  If it is truly /24 then that would indicate that have 256 IP addresses available to you.  I don't have much experience with FiOS, but perhaps they have more going on behind the scenes with their gateway router etc.  On the VIP subnet, it should be /32 as I think you are attempting to configure each VIP individually (In the GUI, IP Address type:single address, inputs /32 as subnet mask).



  • I'll change the subnet on the WAN and see if everything still works.  If so I'll go ahead with what you suggested and let you know how it comes out.



  • The following link is a good resource to help visualize the available IP ranges of different subnets.  We are on a /28 *.32 network from our ISP, with *.33 being the gateway and *.47 the broadcast (unusable), leaving us *.34-46 to use as IP addresses.

    http://krow.net/dict/subnet.html



  • Well unfortunately fios requires a /24 subnet.  I tried with /32 and /30 and it shut off my connection.  So what's next?



  • Try searching the forums for fios - you may need to configure your modem/gateway to behave differently.  I know there was a post recently about similar issues.  Try one of these to start:
    http://forum.pfsense.org/index.php/topic,18855.0.html
    http://forum.pfsense.org/index.php/topic,28100.0.html



  • I was able to use /28 subnet mask and I still have connectivity, however, the virtual ip i did the port forward with is still not working.



  • Neither of the posts deal with business class fios using multiple ip's so they don't really help, but thanks for the effort.  I turned on logging for the rule created by the port forward and I can see the pass in successfully, but I don't see a response.



  • I still have not figured this out.  Any more ideas?


Log in to reply