[ovpn] have i broken somethign



  • Firstly i'd like to apolagise in advance if i'm doing something incredibly stupid as i'm abroad and i'm probably a bit drunk but here goes… (I'm also using a netbook with the resulting compact keyboard, so a recipe for disaster)

    I configured ovpn using the wizard and the client export package (i forget it's exact name but i'm sure someone here will know it)

    It was working perfectly earlier but now it fails to auth every time.

    The response from the sever is to re-prompt for auth and then fail (I'm 99% sure i'm entering the right user/pass)

    The OVPN logs on the client show the following

    Wed Sep 22 23:56:25 2010 OpenVPN 2.1.3 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Aug 20 2010
    Wed Sep 22 23:56:26 2010 ERROR: could not read Auth username from stdin
    Wed Sep 22 23:56:26 2010 Exiting

    I've also tried connecting to my alix 2d3 at home (also running 2.0 b4) which fails

    Wed Sep 22 23:57:44 2010 TCP: connect to <home 3="" 4="" ip="" of="">:443 failed, will try again in 5 seconds: No Route to Host (WSAEHOSTUNREACH)

    Now i'm happy to ignore the problem with the home IP as it might simply be an issue with the config at the ISP (It was working when I tested it last week, but i had a config change @ the isp earlier)

    But regarding the other Pfsense install i'm trying to connect to (cannot read auth username) is that likely to be the client or the server?

    The reason i ask apart from installing/uninstalling bandwithd and ntop (both packages are broken btw) and then installing vnstat I've not updated the server pfsense version since it was working.

    I also have not changed the client ovpn version, and have restarted the client os (winxp)

    Maybe I broke something when i was playing around with the packages.

    I could understand if it was auth rejected but the error "could not read Auth username from stdin" in the logs suggests something broken rather than me simply typing the username/password incorrectly.

    I'm afarid at the moment this is the best information I can give as my firewall rules prevent a direct connection to the admin Interface of pfsense from the wan side unless it's a trusted IP (which this one is not)</home>



  • Upgrading to the latest nightly fixed it.

    I think one of the packages broke a shared libary


Log in to reply