VOIP stumbles before QoS wakes up.



  • I just switched to Pfsense and must say I love it. I use to use Coyote Linux but got tired of the limited updates and features, then switched to dd-wrt but QoS is essentially broken on it.  I read about M0n0wall/pfsense on another forum and found my way here.

    I am having one issue, though.

    Issue at hand is in regards to my Vonage line. I have all the proper QoS rules configured and it does do it's job. I call my cell phone on the Vonage line and listen to either end while swamping the connection with a Speed Test. Without QoS, it's terrible. With QoS, it's just fine…after the first second or two.

    What I mean is, Regardless of which end I am listening to on my Vonage line (Up/Down), when I start a speed test, the sound stumbles for a moment, after that it is fine.  I can download 3GB files and run speed tests while still holding a conversation. It's almost like the VOIP traffic is being thrown in with everything else, but then QoS is like "Oh Shit" and pulls it's head out of the pool.

    The reason this stumble is really pestering me is because when I was using Coyote Linux, this did not happen. That information assures me it is not my hardware. Which would be a 600MHZ Celeron with 128MB RAM. I also like things to be perfect. ^_^

    Does anyone have any ideas to why I am experiencing this stumble? Any thoughts would be praised.

    Dustin



  • There is a field for the vOIP queues that allow bursting.  I wish that I could recall the field name off the top of my head but I believe it is labeled as such.

    Try increasing this to a higher value to allow the initial burst of traffic.



  • I am unable to find anything labeled along those lines. I checked in the actual Queue settings and no go. Is there any specific place it should be?



  • I guess you mean the m1 and d values in the matrix of the queue?



  • @hoba:

    I guess you mean the m1 and d values in the matrix of the queue?

    Yep, that's the ones.



  • Ah, I found the settings now, then.    I went ahead and set them up, but it still stumbles.  I need 128Kb for my vonage setup, but I set the queue at 135Kb. With this new information, I also set the initial burst at 200kb for two seconds..still does it.



  • Strange.  Try 400?



  • I can honestly say that this works well. I had the same problem…..a moment of stutter than voice was okay but rather annoying. I did 400Kb and 5000ms and the problem went away. Thanks for the tip.


Locked