Error installing (filesystem is full)



  • I got this error installing pfsense developer. Running 1.0.1 developer iso.

    Manage to install it to HDD and when bootup on hdd, it will run by it self to proceed with installing the bootstrap loader (I think).

    The installation paused very long at :

    Executing rc.d items...
    Stopping /usr/local/etc/rc.d/dev_bootstrap.sh....
    

    I waited like 2 hours and it still is there. But I can see my ADSL modem is busy so I guess it must be downloading something from the internet. I went to sleep and woke up this morning after about 5 hours.

    I do see something running and now the screen is showing :

    /usr/local/pfsense-clone/usr: write failed, filesystem is full
    

    How can it be full? I got a 10gb HDD which I let pfsense format and partition with (512 swap and rest for /). So I should have around 9gb of space. All full? And I do see something blinking on my HDD.

    Any idea what to do now? Continue waiting? It's like many hours already…...



  • When you install, pick the defaults.  Do not pick a /usr, etc.



  • the problem is, there is no options for me to choose. After booting using the developer iso, I had to setup my internet while in cdrom format. Then I select option 99 to install into HDD.

    Once installation is done, I boot from hdd. Will get a prompt from freebsd bootup manager. I just let the timer expire (which I believe it is choosing default or number 1). Then it will boot up without giving me any options. It straightaway boot until where I have the "unloading dev_bootstrap.sh" screen and pause there downloading something.



  • I tried reinstalling again and again and also tried downloading again from another mirror in case my download is corrupted. But still same. Also tried installing on different machine. Same thing.

    When I don't have internet WAN setup correctly, it will load dev_bootstrap.sh file. But without proper internet connection, the script will produce error :

    
    ...
    ...
    ...
    chmod: /home/pfsense/tools/builder_scripts/*: No such file or directory
    cvpup: not found
    /usr/local/etc/rc.d/dev_bootstrap.sh: cannot create /home/pfsense/tools/builder_scripts/pfsense_local.sh: No such file or directory
    
    

    It asked for wanting to tail the process and I selected "y".

    Any idea?

    edit:
    Hmmm…I pressed CTRL-C to cancel that script and it went back to asking me whether I want to tail the process and this time I presses "n" and it went into pfSense console setup. Strange?



  • now, since I can get into the menu screen, I pressed 8 to go into shell.

    Once in the shell, I ran the command as stated "fetch -o - -q http://www.pfsense.com/~sullrich/dev_bootstrap.sh | /bin/sh" but the file is not there. Then found the file in tools folder. Therefore, ran this

    
    fetch -o - -q http://www.pfsense.com/~sullrich/tools/dev_bootstrap.sh | /bin/sh
    
    

    Hope that's the latest dev_bootstrap file.

    edit :

    Seems to be running fine…it's downloading the cvs now. Looks like going to take a while. Already been running for  2 hours already and still running...how big is the whole download anyway?

    Well...I can see that it's now installing all the freebsd source files. Is it possible not to install those sources? I would rather not waste space downloading those sources that I don't even use.



  • Uh, why did you run the script if you dont want it to do this stuff?



  • err..I only wanted to install the development source for pfsense. Didn't know it will also install the whole freebsd sources.


Locked