Iphone wireless problem



  • All,

    First, let me start by saying that I moved from 1.2.3 which fully worked with both my iphones to the latest 2.0 beta snapshot.  I have an Ath based minipci 802.11g card.  It is configured for WPA2 but the problem is not encrption related as it does it with WEP and no encryption as well.  Also, I am not broadcasting SSID.

    It is strange because all the packets from both my iphone devices (1 an iPhone 3G and one an iPhone4) seem to be randomly dropped.  Seem to drop them more often than not, though the wireless connection stays constant.  I have three laptops and a PS3 which all operate with no problems.  I do not have the LAN and WAP interfaces bridged.  I have tried turning off the packet shaper and turning on UPNP nothing seems to resolve the issue.

    The syptom of all this is that the iphone behaves strangely when checking email adn browsing the web.  About 85% of the time the page loads half way and then times out.

    CPU Type  VIA Nehemiah

    Any ideas what is causing this?  Is this a change on how the wireless is handled in 2.0?



  • I never got it working with an iPhone and a hidden SSID. I guess that is your problem. That doesn't work regardless of router type you use. iPhones need the SSID to be visible AFAIK…



  • That has not been my expereince.  You just have to manually enter the SSID if you have it hidden.  I have tried every different combination to get this to work including unhiding the SSID.

    Something has changed in the ath driver between 1.2.3 and 2.0 Beta4 and it doesn't work properly.  It will associate no problem and I can see my dhcp lease, but like I said about 90% of the time requests time out and I get the endless spinning circle until I turn off wifi on the iphone and use 3G.



  • For me WLAN with 2.0 works flawlessly. Have connected an iPhone, PS3 and an Apple TV…



  • What hardware are you using?  Just curious because maybe it is something specific to my hardware.



  • @jlepthien:

    For me WLAN with 2.0 works flawlessly. Have connected an iPhone, PS3 and an Apple TV…

    jlepthien

    Can you please post a picture of your wireless configuration? I have not yet been able to get the wireless to successfully bridge to the LAN yet and I'm hoping your configuration might provide a clue or two…  ;D



  • Hi guys,

    I am using this system http://www.pcengines.ch/alix2d3.htm

    The internal IP is configured on Bridge, LAN and WLAN do not have any IP address…

    Here are some config shots... http://db.tt/aV8urfS


Log in to reply