Client Installation



  • Hi.
    I installed pfsense strictly following your guides.
    I added 2 user just to find out the behavior of the client.
    On client side (win xp) I set up internet explorer giving the proxy (pfsense address) and port 80.
    When I try to connect to any site I receive a popup with username and password but I don't reach the page I see in the guides.
    I try to put the username and password specified before but I'm not able to go on (the system does not take it).
    Is there something wrong in what I did?

    Thanks
    Giovanni



  • Port 80 is for the web interface.  If you want to use a proxy server you need to install Squid (and use port 3128).



  • Ok, thanks.
    Can you tell me what is the command to install squid?
    Sorry, I'm not an expert!



  • Use the package manager in the GUI, found in the Administration tab.



  • I tried to go to system, packages from the webgui, but I got this error: Unable to communicate to pfSense.com. Please check DNS, default gateway

    Giovanni



  • As the error message suggests, usually that indicates a problem with the DNS server settings in your pfSense server, or the default gateway chosen.  Do as it says and check that those settings are valid.



  • It seems a little bit complicated.
    Is there another way to create a username/password authentication?

    I mean that every single computer on the network is asked for user/password whenever it tries to access internet…
    Thanks
    Giovanni



  • Take a look at the Captive Portal functionality (which is well documented and has it's own sub-forum).


Log in to reply