Two times pppoe with different logins (i386)



  • Trying to use pfSense 2.0 with Telefonica (o2).

    Have setup the modem from Telefonica to pppoe bridge mode, which gives me:
    a) VPI/VCI 1/32, LLC (credentials are login/pass o2@dsl.o2online.de/freeway) and
    b) VPI/VCI 1/35, LLC (credentials are login/pass o2@voice.o2online.de/freeway).

    Setting this up with pppoe WAN interface (vr1 on alix, chose the credentials from a)) and
    clicked on advanced and mlpp, combined this with the vr2 interface and entered the credentials from b).

    The link comes up and only one uplink with one IP is shown (always the second one I enter in the advanced mlpp form).
    Using the Telefonica modem in "routing mode" gives me two IPs.

    Can anyone give me hint what to try best?


  • Rebel Alliance Developer Netgate

    Are you sure that your ISP supports MLPPP?

    I had thought with MLPPP, the credentials for all lines were the same, and you only have one IP address on the bonded link, not one for each line.



  • @jimp:

    Are you sure that your ISP supports MLPPP?

    I had thought with MLPPP, the credentials for all lines were the same, and you only have one IP address on the bonded link, not one for each line.

    That's right. Credentials must be the same, and only one IP is obtained.

    You need to define a separate interface (WAN, OPT1) for each PPPoE link and then you can use gateway groups (under System - Routing) to load balance/failover however you want.
    GB



  • good advise. thank you!

    setup two times pppoe.
    right now one is working.
    Will take a closer look at the system -> routing.


Log in to reply