Squid Install and Uninstall Issues



  • I need some help!!! I tried installing squid and when clicking on the proxy server link I get the below message.

    Warning: main(/usr/local/pkg/squid.inc): failed to open stream: No such file or directory in /usr/local/www/pkg_edit.php on line 53 Fatal error: main(): Failed opening required '/usr/local/pkg/squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/www/pkg_edit.php on line 53

    I rebooted the system and same thing. I tried to reinstall the package and it just hangs. I tried to uninstall the package and same thing, it just hangs and does nothing.

    I tried manaully deleteing everything I could that pertained to squid when ssh into the system using winscp.

    All I did was install the freaking application and it did not work and I can't even uninstall it or reinstall it. WHAT THE HECK CAN I DO????

    Please help. This system is too important to try and rebuild with a new pfsense install.



  • if you already had it installed and tried to update it thats why.
    to uninstall squid when it wont let you uninstall it or update it do the following:
    install squid3, uninstall squid then squid3 then install squid.



  • Ok, so I did exactly what you said to do and I still cannot uninstall squid and to make things worse, I can't uninstall squid 3 either.



  • Make a backup config minus packages then restore. This will work. You'll have to re-install all packages again .



  • That did the trick coldfusion.

    Thanks



  • I was going to recommend the same thing.




Log in to reply