Rate eating up all my CPU



  • Hi!
    Forgive me if this is posted in the wrong place, I am pretty new to this forum.

    I have a weird problem.

    A week ago I found that "CPU Usage" was significantly higher than normal on one of our firewalls* when checking the splash "system status" -page.
    I studied this for a while and thought it was ntop, that when running really increase the load on the firewalls. But it was not running (crashed as usual due to bad way of handeling ram/swap?? any way it was not that). So  I logged in via ssh and noticed this:

    PID USERNAME    THR PRI NICE  SIZE    RES STATE  C  TIME  WCPU COMMAND
    24976 root          1 118    0  3312K  1096K CPU0  0 137.0H 100.00% rate
    566 root          1  4    0  9220K  7180K kqread 0  98:01  0.00% lighttpd

    I have checked the firewall regularly and it works fine, there is really nothing wrong except this rate-program taking all cpu power it can get. All the time.

    I have tried to figure out what rate does and I believe (but I may be wrong?) that it has something to do with "traffic graph"?

    Have any of you noticed something similar. I do not believe that the program should take 100% cpu?

    • Hardware works fine, has worked for several months in a production environment without any trouble:
      Intel Dual Core Celeron 2.x Ghz (2.6?), 1GB DDR2, SATA Harddrive, a number of NICs on different ports.
      Software is latest production release with a few modifications that should not affect anything such as bash is installed etc.

Log in to reply