Interrupt broadcast Storm *Fixed* [BIOS configuration setting]



  • Hi.

    I am now seeing this error in the system logs. Does anyone know what this is?

    kernel: interrupt storm detected on "irq7:"; throttling interrupt source

    update

    vmstat -i indicates irq7 is a parallel printer port.

    What would be the best way to resolve this issue? Could I go into the BIOS and simply reserve the irq or turn off that feature. What do you think?

    thanks, Jits.

    ![interrupt storm.jpg](/public/imported_attachments/1/interrupt storm.jpg)
    ![interrupt storm.jpg_thumb](/public/imported_attachments/1/interrupt storm.jpg_thumb)



  • interrupt storm means high interupt rate. It would probably help to disable the parallel port in the BIOS, then there should be no devices using IRQ7 so FreeBSD should not enable interrupts from IRQ7.



  • Hi. Thanks for the reply.

    Took some looking, but eventually found the Parallel Printer port items in the BIOS and disabled them. PNP/Interrupts irq7 was already set at "reserved" for "Legacy Devices"

    Been long enough now, No more "Interrupt Broadcast Storm" errors.

    Jits.



  • Thanks for reporting back. I'm glad its fixed.


  • Rebel Alliance Developer Netgate

    FYI- sometimes issues like this can also be resolved by toggling the "PnP OS" setting in the BIOS. For FreeBSD, it should be set to 'no' in most cases.

    Disabling devices you don't use is always preferable, though.



  • ok, Thanks. I prefer to turn them off. I'm not at all sure who would need a printer attached to a firewall, unless you've got some type of freaky worldwide RTTY notification system going on.

    I guess the next step will be open source BIOS programs tailored for mission specific open source software. Just a thought.

    Jits.


Log in to reply