Sis0 -lan missmatch problem



  • anyone know how to solve this error my pfsense box is still running beta4 which have 3 NIC (2 X realtek 1X 3com nic) running in dual wan mode. i tried to upgrade the box to version 1.01 to solve a port forwarding problem. i cant port forward from wan2 > lan. now the problem is when i try to install 1.01 it keeps giving me this sis0 lan missmatch error and only detect 2 nics. it cant detect my 3com 905b nic. i tried to change everything in the bios from acpi off to on to reset nvram to setting irq for each and every card and disabling everthing not needed like com port usb port lpt and everything but it still wont be detected. it was detected nicely in beta 4 for some reason 1.01 wont detect it. is this a bug ? i have the same problem installing on another motherboard recently too but i solve it by moving slots. but this motherboard i am installing now only have 3 pci. i cant move the NICs can someone pls help



  • I have a system with 5 3c905 cards that works without issues. Try swapping nics between different slots (swap 3com with onw of the other nics). This is not a pfSense bug, just some hardware oddity. I have had these in the past too with other systems as well.



  • Maybe FreeBSD 6.2 will help.  Try to upgrade to http://www.pfsense.com/~sullrich/1.0.1-SNAPSHOT-11-22-2006/



  • thanks sullrich but i cant seem to download that snapshop build u posted can u post the actual link again ? hoba i tried resiting the nics but still cant detect. i hope freebsd 6.2 solves this problem or i'm stuck with beta4





  • thanks so much. will be testing later thanks again



  • well yup freebsd 6.2 solved it, the error still comes out but the number of nic listed is now correct seems like the freebsd problem but i'm happy now at least it works, 1 more question sullrich is this version u ask me to download a head version with compilers and stuff ? i'm running this in a secure network i need it as secure as possible. thanks again sullrich



  • No, this is not a head version. It only has a newer kernel based on freebsd 6.2 besides some small additions like new rrd-graphs. You are safe.



  • even on this version with freebsd 6.2 it still always detects sis0 or sis1 interface alot even if it doesnt exist. and on this version i get some errors when i partition and install to hdd. just trying to give some info about this version. if u all wanna know the error msg i can post it here. thought it works just fine


Locked