Load balancing 3 DSL links, third not working



  • Hi all!

    Before anything else is said, I searched throughly (or so I think) before posting this, and couldn't find specific information regarding my scenario. If there is an ongoing topic about it, I apologize beforehand.

    I loaded a VMWare VM with pfSense 1.2.3 some days ago, in which 4 NICs get bridged: The local LAN, and 3 WANs (4 mbps each). All three WANs have different subnets (192.168.100.0 (WAN), 192.168.3.0 (OPT1) and 192.168.1.0 (OPT2)). When I fire up uTorrent or Vuze (tried both), 2 out of the three interfaces work at full capability, giving me an average of 800 - 840 KBps dl / 140 - 160 KBsp ul. The third one, however, is scarsely used. Traffic graph reports the third one staying not beyond 20% of its full capability.

    Now, facts:

    • All three internet link-ups have been fully dedicated to this test, so there is no risk someone else is downloading something and disrupting the data.
    • The 'third' interface not working is either OPT1 or OPT2. Never both, but always one of them.
    • If I redirect all traffic to the 'failing' interface only, it immediately starts working at full capability.
    • I have tested many connections (1000-4000+) and few connections (200-500), with very similar results.
    • I've tried chaging pfSense firewall's optimization with no sensible difference.
    • I even tried the 2.0 Beta and the results were rather similar.

    I reckon pfSense is likely not the issue, but I want to be sure. I also would love to have some additional ideas to work with, since I am running out of them. :\

    Thanks for any help given!
    glemDot



  • I believe I found the guilty (altho I am not entirely sure yet).

    I made a firewall rule to load balance all traffic from a specific IP (The machine holding the uT client), and it works.

    I can only assume the rules about routing HTTP or HTTPs were catching some of the traffic. I did not know uT used those ports as well.

    Unless something else comes up, I guess I just solved my issue.



  • Nevermind. It is still happening.

    For hours, two out of the three connections are fully active, while the third is lacking.

    After that, one of the connection goes idle and the former idling one goes at full speed.

    I am monitoring states and it doesn't seem connections get rejected, or anything similar for that matter.

    All three connections were working not too long ago. Whats happening?!



  • Success!

    I copied all the configurations (manually) from my 1.2.3 VMWare VM to a brand new 2.0B4 (Oct 8) VirtualBox VM, and the three ADSL connections are working perfectly fine.

    Could it be that the problem it is not pfSense, but VMWare? I was using Workstation 7.1

    In any case, it seems to be solved! (At last)

    Thanks again guys, for this awesome piece of app!

    glemDot


Log in to reply