PfSense + CF + HDD



  • Hi,
    i have a little box in which is installed pfsense on a compact flash. All works fine. I would like to store squid logs on a hdd ide 2,5''. I added this one, it is reconnized in BIOS. When i choose 8 in pfsense menu to access to shell, i try fdisk and here is the result:

    ******* Working on device /dev/ufs/pfsense0 *******
    parameters extracted from in-core disklabel are:
    cylinders=3830 heads=16 sectors/track=63 (1008 blks/cyl)

    Figures below won't work with BIOS for partitions not in cyl 1
    parameters to be used for BIOS calculations are:
    cylinders=3830 heads=16 sectors/track=63 (1008 blks/cyl)

    fdisk: invalid fdisk partition table found
    Media sector size is 512
    Warning: BIOS sector numbering starts with sector 1
    Information from DOS bootblock is:
    The data for partition 1 is:
    sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
        start 63, size 3860577 (1885 Meg), flag 80 (active)
            beg: cyl 0/ head 1/ sector 1;
            end: cyl 757/ head 15/ sector 63
    The data for partition 2 is:
    <unused>The data for partition 3 is:
    <unused>The data for partition 4 is:</unused></unused>

    i tried 2 differents hdd, same result.

    How can i do that?

    Thanks

    Alex



  • The hard drive you added will have a name that depends on the socket in which you added it.

    You need to specify the correct name for the drive in the fdisk command. It looks to me that you specified the boot drive rather than the drive you added. (Maybe you didn't specify any drive and fdisk defaults to /dev/ad0.)



  • ok thanks, but how can i specify the drive with fdisk?



  • Sounds like you are not specifying a drive at all. Just specify the drive name after fdisk.

    The system startup will show the drives on the system as in the following:

    ad0: 955MB <transcend 20071207="">at ata0-master UDMA33
    . . .
    ad2: 955MB <transcend 20071207="">at ata1-master UDMA33

    (I have two 1GB Transcend DOM "hard drives" on my system and they are named /dev/ad0 and /dev/ad2.)

    I suggest you get to shell command mode and type the command: dmesg | grep ad which will display the startup output which includes the character string ad

    Here's what it produces on my system:

    dmesg | grep ad

    FreeBSD is a registered trademark of The FreeBSD Foundation.
    padlock0: No ACE support.
    agp0: Invalid aperture setting 0x0agp0: Invalid aperture setting 0x0agp0: bad aperture size
    ath0: Ethernet address: 00:19:e0:68:31:4b
    ath0: mac 7.9 phy 4.5 radio 5.6
    rl0: Ethernet address: 00:30:18:b0:50:fb
    uhub0: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub1: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1
    uhub2: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb2
    uhub3: <via 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb3
    rum0: <ralink 0="" 2="" 802.11="" bg="" wlan,="" class="" 0,="" rev="" 2.00="" 0.01,="" addr="">on uhub3
    rum0: Ethernet address: 00:1b:11:b5:c1:c8
    vr0: Ethernet address: 00:30:18:b0:19:48
    udav0: <shantou 0="" 2="" st268="" usb="" nic,="" class="" 0,="" rev="" 1.10="" 1.01,="" addr="">on uhub0
    udav0: Ethernet address 00:60:6e:30:32:26
    udav0: Ethernet address: 00:60:6e:30:32:26
    ad0: DMA limited to UDMA33, device found non-ATA66 cable
    ad0: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad0: 955MB <transcend 20071207="">at ata0-master UDMA33
    ad2: DMA limited to UDMA33, device found non-ATA66 cable
    ad2: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad2: 955MB <transcend 20071207="">at ata1-master UDMA33
    Trying to mount root from ufs:/dev/ad0s1a
    bridge0: Ethernet address: 92:a5:c3:d6:8d:2f
    bridge0: Ethernet address: 36:0f:23:1a:bd:cf</transcend></aborted></ready,dsc,error></transcend></aborted></ready,dsc,error></shantou></ralink></via></via></via></via>

    Then you will know the valid parameter values to the fdisk command; on my system fdisk /dev/ad0 or fdisk /dev/ad2</transcend></transcend>


Log in to reply