Stuck at reboot



  • Hi,

    I read through the hardware section and couldn't find my exact problem discussed. Also saw that FreeBSD and ACPI are not always working well, although it's probably not even ACPI related.

    What happens on my pfS box (Athlon XP on a Nvidia MB) is that when I software reboot through the web interface or pfS console setup, the system starts to reboot normaly but at he boot process gets stuck at "Verifying DMA pool data". What I have to do is to hit the power button, the system powers down, hit the power button again and the system boots normally and goes through the "Verifying DMA pool data" normally. The systems boot normally every time from power off position, but gets stuck on reboots.

    I first thought it was a faulty HDD, so I did a fresh install on a new disk only to get the same problem. Before putting pfSense on this machine  it had Windows XP running for a long time and it had rebooted normally.

    It's not a huge problem because I will probably never have to reboot the system without me being physically there, but still I would appreciate it if you have any ideas of what might be causing this.

    Regards.



  • I too have had problems with an old AMD-box with Nvidia chipset like… 5 years ago, and that machine went straight out through the window.
    First and last time I touched a AMD-based computer for longer than I had to ;-)

    However, my problems was that the system would never boot after the installation was complete, it just stuck at random places during the bootup, however, XP worked fine on the same machine at the time.

    Not to be Biased or anything, but, I've been running intel-computers since 1988 and damned if I'm ever switching :D



  • Thanks for the reply, but this doesn't solve my problem. I'll be using this machine for the time being, moreover I'm quite happy with it's performance - it handles well (50-60% CPU utilization) the 70/70 mbit with a PPPoE on the WAN side at full speed. They are not really comparable, but before this I had a Linksys WRT54GL with Tomato firmware that could only push 30/30 mbit. That PPPoE is really hard to handle, I think.



  • That sounds like some hardware incompatibility.  Have you checked to see if you have the most recent BIOS?  Have you checked what happens if you disable either ACPI or DMA in the BIOS?



  • I haven't tried either. I wouldn't wanna run it without DMA anyway. Wouldn't this put some extra load on the CPU? Will it even run properly with the ACPI disabled?

    Too bad I can't afford the downtime, but I'll try and see how it reacts to both as soon as I can.



  • The lack of DMA for disks should not cause you any problems, I've certainly run firewalls that way before without issue.

    As for ACPI, why would it be a recommended step in troubleshooting boot processes if disabling it would cause the OS to fail to run?


Log in to reply