Did anyone ever figure out how to install nanBSD on WRAP boards?



  • I found this in the "retired" section: http://forum.pfsense.org/index.php?topic=18302.0

    From last year, which seems to suggest its the same issue as the older bios issue on the Alix boards, but I'm running the most current 1.11 bios already.

    I've got 3 older WRAP boards that were running m0n0wall, and would love to use them with PFS.

    (this is the same issue as addresses in the Alix sticky at the top of the forum)


  • Rebel Alliance Developer Netgate

    It's covered on the doc wiki, some searching should have turned it up:

    http://doc.pfsense.org/index.php/NanoBSD_on_WRAP



  • You can download the premoddified images from my space at the university: https://home.zhaw.ch/~maym/



  • Oh, sorry, searching is what lead me to the post referenced above, but I thought it was a dead end.  Thanks, I'll give it a try!!

    Update

    Images worked great, thanks for sharing!!



  • A bit OT, but this week I reactivated some WRAP's with nanoBSD. Not pfSense, but in "googling" some issues there were also some hints to pfSense.

    For the other "Googlers" referring to nanoBSD, here are some News:

    nanobsd on FreeBSD 8.1-RELEASE

    $FreeBSD: src/tools/tools/nanobsd/nanobsd.sh,v 1.51.2.3.2.1 2010/06/14 02:09:06 kensmith Exp $

    There is the variable NANO_BOOT0CFG="-o nopacket -s 1 -m 3" then You need no workaround for the boot issue.

    Another thing is that opposite to the http://doc.pfsense.org/index.php/NanoBSD_on_WRAP article now the second partition works too. I did not tested updates so far, but I am optimistic that this will work too.

    Maybe pfSense could reevaluate to spread a minimal but official WRAP-Build ;-)



  • I also think that pfsense need a specific WRAP distribution.

    I tried to use the modified version from https://home.zhaw.ch/~maym/ but it doesn't work and I can't make pfsense working with my WRAP (while I have no problem with monowall).

    Does anybody have an idea?

    Here is what I get with the modified version of pfsense:

    PC Engines WRAP.1C/1D/1E v1.11
    640 KB Base Memory
    130048 KB Extended Memory

    01F0 Master 044A CF Card
    Phys C/H/S 7818/16/63 Log C/H/S 977/128/63
    /boot.config: -h
    Consoles: serial port
    BIOS drive C: is disk0
    BIOS 640kB/130048kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org, Mon Dec  7 19:59:55 EST 2

    Loading /boot/defaults/loader.conf
    Warning: syntax error on file /boot/defaults/loader.conf
    accf_e
          ^
    Warning: syntax error on file /boot/device.hints
    ISP Firmware
        ^
    Warning: syntax error on file /boot/loader.conf
    ISP Firmware
        ^
    Warning: syntax error on file /boot/loader.conf.local
    ISP Firmware
        ^

    ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿
    ³                                        ³
    ³                                        ³
    ³                                        ³
    ³          Welcome to pfSense!            ³
    ³                                        ³                ______
    ³                                        ³                /     
    ³  1. Boot pfSense [default]              ³          /    f 
    ³  2. Boot pfSense with ACPI enabled      ³        /    \        /
    ³  3. Boot pfSense in Safe Mode          ³        /  p  _
    /  Sense
    ³  4. Boot pfSense in single user mode    ³        \      /     
    ³  5. Boot pfSense with verbose logging  ³        _/       
    ³  6. Escape to loader prompt            ³              \        /
    ³  7. Reboot                              ³                _
    _/
    ³                                        ³
    ³                                        ³
    ³                                        ³
    ³                                        ³
    ³  Select option, [Enter] for default    ³
    ³  or [Space] to pause timer  9          ³
    ÀÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÙ

    /boot/kernel/kernel text=0x739788 inflate: invalid stored block lengths

    readin failed

    elf32_loadimage: read failed
    /boot/kernel/kernel text=0x739788 inflate: invalid stored block lengths

    readin failed

    elf32_loadimage: read failed
    can't find 'kernel'
    |
    Hit [Enter] to boot immediately, or any other key for command prompt.
    Booting [/boot/kernel/kernel]…
    can't load 'kernel'

    Type '?' for a list of commands, 'help' for more detailed help.
    OK

    Thanks

    Cheezs



  • After a whole week of problems, I forgot the idea of installing pfsense on my WRAP.
    I finally installed a freebsd from scratch on a CF. It works very nice and I have included a samba PDC for my small network.

    Maybe someday there will be a wrap version of pfsense!


  • Rebel Alliance Developer Netgate

    Is your WRAP on the most recent BIOS version?

    I have a WRAP and last time I tried it, it worked fine. The WRAP is no longer manufactured or supported by its creator. Given its age, and the fact that the ALIX is a much better replacement for it that is supported, I doubt any heroic measures will be taken to make an "official" wrap-specific image.


Locked