DNS Rebind attack detected



  • With the old pfSense you could go to system > advanced, and check "disable nat reflection", and would then be able to see what was on your own ip.

    In 2.0 if I go to system > advanced > Firewall / NAT they are already checked, and I get this

    Potential DNS Rebind attack detected, see http://en.wikipedia.org/wiki/DNS_rebinding
    Try accessing the router by IP address instead of by hostname.

    If I try to open the web server located on my own ip.

    Is is not possible to do that any longer?



  • I was also seeing this. Rebooted Pfsense and it hasn't returned so far - hope that works for you too.

    2.0-BETA4 (i386)
    built on Wed Oct 20 05:22:55 EDT 2010



  • Been playing a bit more around with it, and still no luck…

    But instead of showing me the warning, it takes me to the login prompt for pfsense, which is not what I want either.

    If I change the ports away from the default http 80 and https 443, it is just getting a timeout instead.

    Don't know if this is a bug, or how it is supposed to work.


  • Rebel Alliance Developer Netgate

    You are hitting the WebGUI if you get that error, not your own server.

    Move the WebGUI to an alternate port (Not 80 or 443) and check "Disable webConfigurator redirect rule" under System > Advanced.



  • @jimp:

    You are hitting the WebGUI if you get that error, not your own server.

    Move the WebGUI to an alternate port (Not 80 or 443) and check "Disable webConfigurator redirect rule" under System > Advanced.

    I tried that too, makes it time out instead


  • Rebel Alliance Developer Netgate

    Then we'd need to see what your port forward rules look like in the GUI.



  • I don't use it any longer, switched back to 1.2.3 because I couldn't get it working as I needed it to. But will try again when it is getting closer to a release. :)



  • I am having this same issue.  I know my NAT is working fine because it works great if I hit the IP from an external network.  But as soon as I try and hit it from within my pfsense network, it always redirects.  Its doesn't matter what port webGUI is running on or whether that redirect box is checked or not.


Locked