PfSense 1.01 won't boot



  • Been using pfSense for some time, and had no problems till now.

    I am using an old FireBox II hardware (Pentium 200MMX, 128MB RAM, 2.5" 12GB HD, 3x 10/100), which ran BETA4 just fine.
    Since there is no way of attaching a CD drive to this box, I used another computer to install from LiveCD onto the HD, then
    moved it to the FireBox. pfSense 1.0 & 1.01 won't boot; it locks hard with the following lines on screen:


    atkbd0: [GIANT-LOCKED]
    psm0: current command byte:0065

    and that's it. The only option I have at this point is hard reset.
    The same HD boots just fine when attached to another system (Pentium Pro 200).

    Any ideas?

    Thanks,
    alexf



  • Try turning off floppy support in the BIOS.



  • Floppy controller is turned off. This advice is something I got out of the forum while searching for anyone with a similar problem.

    thanks,
    alexf



  • Perhaps this snapshot may work for you then.

    http://www.pfsense.com/~sullrich/1.0.1-SNAPSHOT-11-30-2006/



  • It's always possible that you have a faulty keyboard controller. I had entire batches of motherboards that age start getting flakey (ie keyboard locking up) and finally the keyboard wouldn't even work anymore. They were all PII era intel boards, built by gateway.

    You might try using a usb keyboard (if you are so lucky), unfortunately most boards that old do not allow you to disable the ps2/keyboard controller. Although there may be a jumper that lets you do this.

    Just a thought…



  • If it's really keyboardrelated you could try using the embedded image. It doesn't have support for keyboard and video at all so maybe it will work for you. Output is at com1 so you will need a serial nullmodemcable to see the bootup and configure the interfaces initially.



  • I had 1.0.1 working ok under :
    pfSense-Full-Update-1.0.1.tgz (October release)

    I loaded the latest snapshot :
    pfSense-Full-Update-1.0.1-SNAPSHOT-12-06-2006.tgz

    Now, the PC does not boot-up.
    The display shows :

    …...
    Loading /boot/defaults/loader.conf
    Unable to load a kernel!

    Can't load 'kernel'

    I will try a clean install

    Later addition : Clean install worked ok



  • sullrich:
      Perhaps this snapshot may work for you then.
      http://www.pfsense.com/~sullrich/1.0.1-SNAPSHOT-11-30-2006/

    That did it! It works now  ;D
    Either the snapshot made the difference, or fiddling with the machine made something go 'click'… ;)

    It still pauses for about 10-15 seconds at the exact point it used to lock-in before, but then continues and boots.

    Sullrich, thanks alot, and a little Q: is there a time-frame for final PFSense release with FBSD 6.2?

    Thanks again,
    alexf



  • Whenever FreeBSD 6.2 is released.


Locked