Enabling Single link MLPPP



  • I recently made the jump to the PFsense 2.0 beta in the hopes of enabling Single Link MLPPP now that MLPPP support has been added and the system as a whole seems to be reasonably stable. However, I'm unsure of where to proceed from here. My attempt to get it running by linking vr0 and the WAN interface in the MLPPP dialog didn't break anything, but it didn't seem to enable SLMLPP either. Does anyone have any ideas on what I can do to get things running?

    I'm currently running pfsense 2.0beta4 embedded on an ALIX 2D13



  • I don't know that pairing a dummy interface with a valid one will work to enable single link mlppp, but it sounds plausible. You don't want to choose the WAN as a member interface though. Pick an unused physical interface for your dummy link. If you don't have an unused physical interface you will have to use a vlan, keeping in mind that the vlan won't show up as a choice until you have first assigned it as an OPT interface and then enabled it as either dhcp or static. Then once you have created the pppoe0 interface in ppps, go back to interfaces_assign.php and designate the pppoe0 bundle as your WAN.

    Does that make sense?

    And then please report back with your result. You're not the first to ask about slmlppp.



  • Just to make sure I have this straight. I could pair say, OPT1 with vr0 to create the 2 links necessary for MLPPP through a single link? And would I still use the physical WAN port or should I switch it to OPT1 instead?



  • Your hardware has 3 NICs, vr0, vr1 and vr2. Let's say for example you want to connect your modem to vr0. vr1 will be your LAN. vr2 will not be plugged, but will act as the dummy link in the bundle, like this:

    vr0–modem
    vr1--LAN switch
    vr2--unplugged

    1. Go to interfaces_ppps.php and delete every entry.
    2. Click the + sign to make a new entry.
    3. Choose type: pppoe. Link interfaces: select vr0 and vr2 (using the ctrl key).
    4. Save and go to interfaces_assign.php.
    5. You need exactly 2 entries here. WAN: PPPOE0(vr0,vr2) and LAN: vr1 (00:00:00:00:00:00). Save and apply as needed.

    That's it. These instructions only work if you have a physical port that's not in use. If you're using all your physical ports then you'll have to go about it a little differently with vlans. Let me know if you want instructions for that.



  • I just finished setting it up. The only snag I ran into was that I wasn't sure what to assign interface OPT1 to, as I couldn't assign it as an MLPPP connection and I couldn't get rid of it as the interface was part of a bridge. I ended up just assigning it to bridge0 for the time being. If it causes any problems I can always switch it out.

    EDIT: This MLPPP setup seems to be working perfectly. However I am thinking of utilizing the spare OPT1 port at some point in the future. What kind of changes would I have to make in order to accommodate not having a spare OPT1 port handy?



  • If you want slmlppp and you don't have a spare physical interface, then you need to create and use a vlan interface as the dummy. The gotcha here is that a vlan interface won't show up in the interface list when you're selecting your pppoe bundle members unless you have first enabled that vlan as a static or dhcp interface.

    Creating vlans in pfsense is effectively free, so just make a vlan on your WAN or some other port, so for example vr0 is your WAN, and you also create vlan 999 on vr0 and assign it as OPT2 (because vr2 is now OPT1). Enable OPT2 as a static IP address that does not fall on one of your existing subnets, and then go to ppps and make a pppoe bundle from vr0 and OPT2.



  • Perfect, Thank you for your help. It's much appreciated



  • @clarknova:

    If you want slmlppp and you don't have a spare physical interface, then you need to create and use a vlan interface as the dummy. The gotcha here is that a vlan interface won't show up in the interface list when you're selecting your pppoe bundle members unless you have first enabled that vlan as a static or dhcp interface.

    Creating vlans in pfsense is effectively free, so just make a vlan on your WAN or some other port, so for example vr0 is your WAN, and you also create vlan 999 on vr0 and assign it as OPT2 (because vr2 is now OPT1). Enable OPT2 as a static IP address that does not fall on one of your existing subnets, and then go to ppps and make a pppoe bundle from vr0 and OPT2.

    I'm still pretty new to pfSense and while I understand using a second vlan as a dummy interface, performing the actual steps are a bit daunting to me.

    If I understand the steps correctly:

    1. Interfaces > VLAN > Create new VLAN for dummy interface
    2. Interfaces > Assign > Add new interface (select newly created VLAN)
    3. Interfaces > OPT1 (in this case) > set IP config to static or DHCP
    4. set up mlppp using WAN and OPT1?

    I'm on Teksavvy and I'm trying to set up mlppp to work on pfsense.



  • 3. Go static or startup time will be delayed by a lot.
    4. Use OPT1 and the physical interface of the WAN, I.e. vr0 (or the blank name as applicable, ie, vr0_vlan10).



  • I followed those steps but have been unable to get a stable single link mlppp connection going.  The PPP log shows that pfSense connects but then immediately disconnects.  Any suggestions on what I should be checking?



  • What snapshot are you using? There are issues with pppoe in the latest.

    http://forum.pfsense.org/index.php/topic,31247.0.html



  • I'm currently running 2.0 beta 5 (Dec 25th build).

    I created VLAN 999 on em0 then added OPT1 and enabled it (set the IP to my static IP from my ISP)
    then I went into the PPP menu and modified my connection (added OPT1 to the bundle)
    then the connection goes offline for a minute or two while it attempts to reconnect (pages will load then when you click a link the connection is lost)

    a regular PPPoE session works without any issues



  • OPT1 should have a static IP that is private and not the address from your ISP.



  • I changed the IP address and still no go.  The PPP log shows:

    Dec 29 20:25:38 ppp: [wan_link1] PPPoE connection timeout after 9 seconds
    Dec 29 20:25:38 ppp: [wan_link1] Link: DOWN event
    Dec 29 20:25:38 ppp: [wan_link1] LCP: Down event
    Dec 29 20:25:38 ppp: [wan_link1] Link: reconnection attempt 1 in 4 seconds

    repeatedly when I bundle em0 and OPT1 in as my PPPoE connection



  • For those who want to push the envelope with mpd you can craft a custom mpd.conf file and place it in your /conf directory. pfSense will check there first before starting mpd. If it finds a conf file for the interface in question (e.g. if interface is WAN then it looks for /conf/mpd_wan.conf) it will use it for the configuration of that link.

    You can use the GUI to configure mpd for the first time and then just copy the auto generated .conf file from /var/etc/mpd_wan.conf to /conf/mpd_wan.conf. Then make your changes and viola, you're good to go! You can do any variation that mpd allows.

    If you want to enable slmlppp, you could set up a normal, non-mlppp interface with pppoe, then just add this line:

    set link enable multilink

    in the section of other "set link" commands in your /conf/mpd_wan.conf file.

    GB

    [this is from the code that configures all ppp type interfaces]
    if (file_exists("{$g['conf_path']}/mpd_{$interface}.conf"))
    mwexec("/bin/ln -s {$g['conf_path']}/mpd_{$interface}.conf {$g['varetc_path']}/.");



  • @surrealillusion:

    I changed the IP address and still no go.  The PPP log shows:

    Dec 29 20:25:38 ppp: [wan_link1] PPPoE connection timeout after 9 seconds
    Dec 29 20:25:38 ppp: [wan_link1] Link: DOWN event
    Dec 29 20:25:38 ppp: [wan_link1] LCP: Down event
    Dec 29 20:25:38 ppp: [wan_link1] Link: reconnection attempt 1 in 4 seconds

    repeatedly when I bundle em0 and OPT1 in as my PPPoE connection

    Those messages are telling you that OPT1 is not able to establish a pppoe session, which is normal in your case because OPT1 is your dummy interface and not connected to a modem. You would see these message even if you had a working slmlppp connection on em0.

    gnhb has given you a better method for what you are trying to accomplish and I suggest you try that route.



  • Finally got around to trying that alternative method and it worked, finally able to enjoy proper torrenting speeds once again, thank you all for your help!


Locked