Nat Problem … Interface adress ?



  • Hi!  ;)

    Im using Pfsense with 1 Wan and 1 Lan … Simple right ?

    ok ... the system is working fine ...

    I´ve installed the upnd package to work with dc++... On the pfsense/upnd page it gets the ports ... but the dc++ dont work ...
    i dont understand the problem ... maybe the upnd need some extra rule on the firewall...

    after that ... i have created the nat rule for the dc++ but it seems to do not work too....

    Now im testing with the 4662 emule port ... because on the emule url it has a utiliy to check if the port is available from outside and it´s correct ... "TCP test failed!"

    My Wan is a ppoe (conected to a WAG54G in bridge mode) ... so ... when im creating the rule we have to put the external adress ... but if i put that it appears (ext: ) like on the photo ... its correct ?

    i dont understand why is so dificult to creat a nat rule LOL -  ???

    do i need to create a rule on the wag54g in bridge ? (i dont believe)
    thank you :)




  • The WAG54G is an adsl router and you have it in bridge mode. Seems to me that there might be some sort of firewall enabled on it blocking incoming connections. I would check this out first since you can't get any NAT rules to work properly.



  • ok …

    in my teory when we have a router in bridge mode ... the external ip is not on the router but ... on the Wan Nic ... so there´s no firewall on wag54g ... tell me if i´m rong :| lol

    I´ve tried to put the modem on ppoe but it dont work to ... i´ve tried to put on the router the Dmz ip equal to the pfsense wan ip ... but no sucess ...

    I think the wag in bridge mode is the best way ... but ... anybody have the same nat problem ?

    help!! LOL  ???  ???



  • Putting it in bridge mode is the correct way. However firewall rules still take affect when in bridge mode. For example you can run pfSense in bridge mode and use it to filter traffic. I looked at the manual for the WAG54G and I recommend on the security tab disabling the firewall protection.



  • Another thing you could try is using RFC 1483 Bridge mode instead of Bridged Mode Only. The RFC mode allows the WAG54G to make the PPP connection and validate your username and password. After that is complete it will pass the public IP from the WAG54G to the pfSense box.



  • Ok … im @ work now ... but ill try that way ...

    Thank you for your help  ;D



  • ;( it dont work :| in the bridge mode that you said we still have to make the autentification on the pfsense machine…

    but it still dont work ...

    how do i have to configure the wag54g ?



  • Im thinking … why in ppoe mode when i´m creating a NAT rule it apears (ext: ) and on dhcp it apears (ext: WanIp) ? it´s normal!



  • Yes, it's normal. All my portforwards at pppoe work and do show "ext:" too. It's only a cosmetic thing not showing an IP there.



  • there is an option on the wag54 "nat = enabled" it´s correct?

    i dont know what to do … if I was on dhcp ... I´ll configure the DMZ ip on the router to the ip of the pfsense ... but ... on ppoe ... the wan dont have a Valid Lan IP ...

    Tell me what are the defaults rules on the Firewall - Rules options to work...

    ???

    thank you all ...



  • This really is a configuration thing of the WAG54 and I don't know it. Maybe a really "dumb" pppoe modem with no features would serve you best.



  • the problem it´s that i have a netgear adsl modem … but ... it only have ppoe and ppoa and not bridge...

    and i´ve tried to put this modem on ppoe and the pfsense in dhcp and configurated the DMZ ip of the netgear to the pfsense ... and the same problem ;(



  • good news …

    i´ve searched and ... i´ve founded a way to put the netgear on modem modem... and it still dont work ;(

    i´ve updated the pfsense ...

    still dont work ...

    witch are the firewall rules ?



  • Ufff!! :)

    i´ve found the problem :)

    if i have the captive portal active … the nat rules and upnp dont work ... What do i have to do ?

    Sorry guys .. and thank you :)


Locked