Adding havp lightsquid no longer logs*SOLVED*



  • Hello All,

    pfSense-1.2.3-RELEASE
    2 wan
    1 lan
    squid
    squidGuard
    LightSquid

    Just added HAVP, now Lightsquid no longer logs any http traffic. I have tried every combination of squid & havp, Parent ,Transparent,etc.
    I can get havp to log to it's own file if I visit the eicar test site by client ip address.
    Ideas?

    Thank You,
    Barry



  • LightSquid work only with squid



  • dvserg,

    Thanks for responding.
    So squid can no longer log its http traffic to Lightsquid,is what you are saying?…
    I thought it would be possible for havp to log to its log file,and still have squid log to its http traffic log?.

    Thanks Again,
    Barry



  • For Lightsquid you need only squid logs. For begin - check you squid log settings, and squid log rotation.



  • dvserg,

    Lightsquid has worked flawlessly up until havp was installed,,I changed nothing other than NO transparent proxy on squid itself,,,now.
    Also just for clarity SquidGaurd is installed also.
    I don't really know troubleshooting technique for this?
    We have to have Lightsquid working for a means of student discipline if the need would arise as well as legalities.

    EDIT:  Fixed.
    I finally got everything between havp and squid to work/log correctly by setting havp to "parent mode"
    I could not get havp to work in parent mode for some time as I was entering the squid ip address:proxyport in the Parent proxy  line in the havp gui. No clients could browse with this set. Once I tried "Parent mode" with a blank line in the Parent Proxy line of havp gui, then everything worked as expected. That is kind of confusing.

    Sidenote: I never could get the clients ip address to show up in Lightsquid,with havp in "transparent mode". The only IP address that was logged by squid was the actual pfSense ip address? We could not have this in a school environment.
    Sorry for long post.

    Done
    Thanks to the havp dev-team!…:)

    Barry



  • I'm having same issues with getting client ip address to show up on lightsquid. I'd tried the setting on the very bottom of this page http://doc.pfsense.org/index.php/HAVP_Package_for_HTTP_Anti-Virus_Scanning still no dice… anyone figured this one out yet?

    My current scheme: {inet} - [Squid] - [havp] - {clients}


Locked