Can't configure squid from WebGUI



  • Hello everyone,

    Couldn't find any useful hints, so I'm posting here. Due to several issues, I had to reinstall Squid on my pfSense. And by reinstall, I mean uninstall - install again.

    Since I did this, it has been completely impossible to change the config of Squid from the webGUI. When I change a parameter and click "save", the page keeps "loading", with no effect. I tried a top, apparently there is a php process going crazy for 5 to 10 minutes as soon as I click save, then the page times out, and my changes are not saved.
    Moreover, webgui pages for squid take several seconds to load …

    Just so you know, I am running my pfSense as a virtual machine on a VMware ESXi server, and I seem to have some issues with interrupts. But it used to work, so I don't know why it wouldn't work now :/

    Has anyone ever experienced this kind of issue ? I would like to have it back as soon as possible, because I critically need throttle on my network, and to be honest, I've been trying to fix this issue for several hours because I would hate to have to reinstall a whole pfSense because of squid :(

    Cheers,
    Daniel



  • Do you have a backup from back when things were working?  In some cases, a full reinstall/restore is the quickest solution.

    If not, did you manually uninstall the package from the shell or did you use the GUI?  If you used only the GUI, I would uninstall the package, reboot.  Reinstall the package, reboot.  Try everything again.  Also, I assume you are talking about squid 2.7 and not 3.0?



  • Hi,

    Thanks for your answer, and you got it right, I used squid 2.7. I tried a full reinstall, but it didn't unclog the server … Neither did the GUI reinstall, and the reboots.
    After struggling a few additionnal hours, I just gave up, a reinstalled the whole VM, and luckily the problem was solved.

    Note that on my clean reinstall, I chose not to install Lightsquid, as I thought it might be the problem - although it had worked fine before ...

    Anyway, thanks for the answer,
    D.



  • Hi Kehrlann, I have the same issue with pfsense 1.2.3 and Squid 2.9 running on dedicated and powerfull hardware.
    I can´t modify any parameter of squid webGUI config page.
    I tried to reinstall the squid package with unuseful result.

    I will keep trying…

    Patricio



  • Hi again….

    I tried this solution in this post and work´s fine now:

    http://forum.pfsense.org/index.php/topic,28029.0.html

    Please read the jimp post about a <config>in config.xml file.

    Patricio</config>


Log in to reply