64bit 20101110-0242 Panic on root filesystem mount



  • Just tried testing the 20101110-0242 64bit build it panics trying to mount the root filesystem from CD during the install process. I've verified the download and reburnt CD just to be safe.

    Server is a Proliant DL360 G7 2 x 12 core at 3GHz and 12 gig of ram.

    The 32bit installs fine on the same server but as I'd like to test both PFSense 2 and BGP with full internet routing tables the 64bit version is the preferred option (to many memory problems on 32bit trying to deal with all those routes, unless someone has a magic tweak I've not come across)

    FreeBSD 8.1 64bit installs and runs fine so I'm not quite sure what is going on.

    All help, advice or chocolate biscuits gratefully accepted.



  • I've tried this on some older HP servers and even on a PC with a single AMD chip and can't get it to boot.

    Can anyone confirm they have booted and installed it on physical hardware.


  • Rebel Alliance Developer Netgate

    Can you get a picture or capture the output of the panic in some way?

    Does it work if you use an older ISO to install (Maybe from 2-3 weeks ago), then do a firmware update?



  • I have booted pfSense 2.0-BETA4 20101112 amd64 version on a HP DL 360 G7 server with the latest firmware updates from HP, then I installed pfSense on the hard drives, everything went fine.

    The DL360 G7 serie has a LOT of firmware upgrades to apply, regarding BIOS, RAID controller, ILOM etc etc. I strongly suggest the original poster to apply all those upgrades and then try again.

    Regards,



  • Sorry for the slow response but I'm on leave and relaxing :)

    yes all firmware and bios upgrades are applied As I said no problems with FreeBSD 8.1 installing.

    I'll try with the latest 64bit build when I get back next Monday as the 32 bit build just can't handle all the routes supplied by BGP.

    Jimp, if it still fails I'll find some way of getting a screen dump.

    I'm very keen to see the 64bit version move forward so I'll be putting a lot of time into testing this and hopefully resolve a few bugs.



  • Just installed 20101122-0218 with no issues. Will now start some serious testing :)


Log in to reply