Need to set 100Mb full-duplex



  • I am running 2.0 Beta4 built on Tue. Nov. 9th 2010 on a Dell Poweredge 2850 with 2 onboard Gb Nic's. I have a 20Mb connection coming into my office. My ISP requires that I set the WAN NIC to 100baseTX full-duplex. I have read all of the posts in the forums and have tried to make the changes suggested.  I have edited the /cf/config.xml file and entered the lines,
    <media>100baseTX</media>
    <mediaiopt>full-duplex, when I rebooted the system the file was overwritten.
    I found another post that added the lines,
    <bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>, again the file was overwritten on reboot.
    I have tried the "ifconfig em0 media 100baseTX mediaopt full-duplex" command but I cannot get the interface to show as anything other than half-duplex. The "ifconfig -m em0" command tells me that these settings are supported on this NIC.
    Any suggestions would be greatly appreciated.</mediaiopt>



  • Hi,

    I have the same Issue, I must set the media to 100baseTX FD, and the xml config is erased (I tried downloading the interface config, modifying the xml, uploading / re-downloading).

    After the upload of the config, I go to Status > Interfaces and the media is still on autoselect, although I reboot.


Log in to reply