Snort install fails



  • Not sure if this is Snort or a ofSense 2 problem - so sorry if in wrong forum

    Running latest - i.e. current - version of pfSense - full version running squid, squidguard tried to install snort and it failed as below.

    Any ideas

    Thanks

    Andrew

    Beginning package installation for snort…Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading snort and its dependencies... Checking for package installation...
    snort-2.8.6.1  (extracting)
    pcre-8.10 done.
    Loading package configuration... done.
    Configuring package components...
    Additional files... snort_check_cron_misc.php failed.
    Removing package...
    Skipping package deletion for pcre-8.10 because it is required by other packages.
    Starting package deletion for mysql-client-5.1.50_1...done.
    Starting package deletion for snort-2.8.6.1... Starting package deletion for pcre-8...done.
    done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Failed to install package.

    Installation halted.



  • Please update to latest snapshot there was a timeout problem fixed yesterday.



  • I have the same problem and I have upgraded to the latest snapshot; 2.0-BETA4 (i386)
    built on Thu Nov 18 02:10:52 EST 2010



  • same thing happen to me, failed at snort_check_cron_misc.php
    pfSense 2.0-BETA4 (i386) built on Thu Nov 18 02:10:52 EST 2010

    I suspect something change in the snapshot lately since it just happen in the couple of last snapshot.



  • Just finished recovering from updating to the latest snapshot about an hour ago.

    Squid failed, squidguard failed, ipsec failed - many depenedencies failed

    Gone back to 20101116-1840 may not run snort but at least iw runs everything else we need

    Regards

    Andrew



  • i tried to install snort in 1.2.3 but i got path error and compress_depth and binary errors etc.i fixed a few errors but after a while i gave up, and changed to 2.0 beta now i got snort_check_cron_misc.php error : /

    What to do?

    edit: if someone have other ids as suggestions i will be open to try a few of them. but all configuration most be over webgui interface.





  • yes, it work in the latest version:
    pfSense 2.0-BETA4 (i386) built on Sun Nov 21 02:37:38 EST 2010

    but the GUI is still broken as mentioned in http://forum.pfsense.org/index.php/topic,30084.0.html


Log in to reply