I386 - latest snapshots - very recurrent kernel panic



  • hardware : stock HP Proliant DL 380 G3 (latest bios firmware etc)
    config : lagg interface across the two onboard Gb NICs, multiples VLANs on it, multiple carp addresses (backup)
    crash is recurrent, usually after a couple of minutes of activity, as well with server purely idle and sitting doing nothing



  • Can you post a back trace?



  • sorry for asking, but, how do I do this ?



  • never mind my question here is the back trace




  • I tried to upgrade my ALIX nano 'built on Sat Oct 23 01:36:14 EDT 2010' to the new version 'Fri Nov 19 00:17:38 EST 2010' using auto update and got kernel panic as well

    
    Fatal trap 12: page fault while in kernel mode
    cpuid = 0; apic id = 00
    fault virtual address64 = 0x999f7746
    fault code        1  46 = supervisor read, page not present
    instruction pointer  44 = 0x20:0xc095da2f
    stack pointer           = 0x28:0xe2d264ec
    frame pointer           = 0x28:0xe2d264fc
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = interrupt enabled, resume, IOPL = 0
    current process         = 11 (irq11: vr1)
    trap number             = 12
    panic: page fault
    cpuid = 0
    Uptime: 1m52s
    Cannot dump. Device not defined or unavailable.
    Automatic reboot in 15 seconds - press a key on the console to abort
    
    

    I will try to reproduce and get a back-trace a bit later.



  • Can you tell me if you have vlan tagging on or off in the interfaces?
    Or just show the output of ifconfig command.



  • I appear to be hitting this same issue. I also have an Alix board running the 4g nanobsd image. Updating from the webGUI or the console gives a fatal trap nearly identical to azzido's. I'll post it momentarily.

    Here's my ifconfig output:

    vr0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
            options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:1c:73:48
            inet6 fe80::20d:b9ff:fe1c:7348%vr0 prefixlen 64 scopeid 0x1
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:1c:73:49
            inet6 fe80::20d:b9ff:fe1c:7349%vr1 prefixlen 64 scopeid 0x2
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:80:48:6c:b4:a3
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
            status: running
    pflog0: flags=100 <promisc>metric 0 mtu 33108
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
            nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128
    enc0: flags=0<> metric 0 mtu 1536
    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
            inet 97.x.x.176 --> 207.225.140.218 netmask 0xffffffff
            inet6 fe80::20d:b9ff:fe1c:7348%pppoe0 prefixlen 64 scopeid 0x8
            nd6 options=3 <performnud,accept_rtadv>ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
            ether 00:80:48:6c:b4:a3
            inet6 fe80::280:48ff:fe6c:b4a3%ath0_wlan0 prefixlen 64 scopeid 0x9
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
            status: running
            ssid houseofhacks channel 8 (2447 MHz 11g) bssid 00:80:48:6c:b4:a3
            regdomain FCC country US ecm authmode WPA2/802.11i privacy MIXED
            deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit txpower 30 scanvalid 60
            protmode OFF burst dtimperiod 1 -dfs
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 4a:1b:c4:c9:31:14
            inet 10.10.254.1 netmask 0xffff0000 broadcast 10.10.255.255
            id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
            maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
            root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
            member: ath0_wlan0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 9 priority 128 path cost 370370
            member: vr0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 200000</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,promisc,simplex,multicast></performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></hostap></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,promisc,simplex,multicast>
    


  • @ermal:

    Can you tell me if you have vlan tagging on or off in the interfaces?
    Or just show the output of ifconfig command.

    if the question was adressed to me, yeah, vlan tagging
    my lagg is a trunk to my catalyst 3560, there is around 7 or 8 vlans



  • Here is my ifconfig and I am not using VLANs

    
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:15:5e:e8
            inet 192.168.100.1 netmask 0xffffff00 broadcast 192.168.100.255
            inet6 fe80::20d:b9ff:fe15:5ee8%vr0 prefixlen 64 scopeid 0x1 
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:15:5e:e9
            inet6 fe80::20d:b9ff:fe15:5ee9%vr1 prefixlen 64 scopeid 0x2 
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:15:5e:ea
            media: Ethernet autoselect (none)
            status: no carrier
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:0b:6b:xx:xx:xx
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
            inet6 ::1 prefixlen 128 
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6 
            nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128
    enc0: flags=41 <up,running>metric 0 mtu 1536
    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
            inet X.X.X.X --> X.X.X.X netmask 0xffffffff 
            inet6 fe80::20d:b9ff:fe15:5ee8%pppoe0 prefixlen 64 scopeid 0x9 
            nd6 options=3 <performnud,accept_rtadv>ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:0b:6b:xx:xx:xx
            inet6 fe80::20b:6bff:xxxx:xxxx%ath0_wlan0 prefixlen 64 scopeid 0xa 
            inet 192.168.102.1 netmask 0xffffff00 broadcast 192.168.102.255
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
            ssid XXX channel 1 (2412 MHz 11g) bssid 00:0b:6b:xx:xx:xx
            country US ecm authmode WPA2/802.11i privacy MIXED deftxkey 3
            AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 22 scanvalid 60 pureg
            protmode OFF burst hidessid -apbridge dtimperiod 1 -dfs</hostap></performnud,accept_rtadv></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></up,running></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></hostap></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast> 
    


  • so is it something that would be under investigation ?
    should I try once more with newer snaphosts ?

    thanks for your hard work



  • Maybe this is a separate issue, but I am getting kernel panic after client connects to PPTP VPN. It occurs from 15 seconds to 15 minutes after PPTP connection. Interfaces are: single fxp and two rl. VLAN is not used on router which have that issue. pfSense itself is configured as PPTP server. PPTP tunnel has separate /24 network from internal networks. Without PPTP clients connected, router works fine. This issue has appeared after update to some Novebmer's build - can't say for sure after which exactly. Dont' have a possibility to connect via console to provide more informative logs as router is located on remote site.

    2.0-BETA4 (i386)
    built on Tue Nov 23 10:24:54 EST 2010




Log in to reply