Setup for internet site using static ip on port 80.



  • Hello all,
    I'm in the process of trying to setup a internal website using IIS.
    The IP for the website is set to our static address of 7X.4X.1XX.2XX on port 80.
    The website is being hosting on a internal machine using 192.168.0.94

    I am completely new to the PFSense community and I have searched through looking for a similar thread for the similar setup.

    I need to know what I need to open in NAT, and anything else I need to know.

    Currently the only thing I can hit is our firewall with HTTPS.

    Could this be the problem?

    We have no domain, so to my understanding, DNS doesn't need to be used.

    Please help. ;)



  • Go to firewall>nat, portforward.
    Hit the plus icon.
    create a portforward on WAN, external adress interface adress, protocol tcp, external range http, nat IP <lan ip="" of="" server="">, local port http.
    Make sure to not uncheck the autocreate firewallrule.
    Save and apply.</lan>



  • Thank you so much!!!  :D



  • Same situation as this guy but setting the NAT rule did not help, any other ideas?



  • Some ISPs filter port 80 to prevent people running their own webservers. Try a different port. if this works you ISP is doing some filtering.

    Oh, and make sure you have "external adress: interface adress" and not "any".



  • My ISP doesn't filter b/c previously I had a Linksys router and was able to host a server but for some reason with pfsense all I can get is the admin panel.



  • Then you nat rule is wrong. Delete everything you setup for this and start over and follow my first answer in this thread.



  • Ok, I promise I am not trying to be difficult but that is exactly what I did when I read your post. Wan, Interface Address, TCP, HTTP, <lan ip="">, HTTP. I even went ahead and restarted although I am running 1.01. BTW the main reason I know I'm not being filtered is that I do get the pfsense admin panel. Also, and I may have just been misreading this but do I have to turn on Nat Reflection for any reason for me to connect to my webserver? (read through a post about getting a quake 4 server to work.)</lan>



  • Then I really don't have a clue  :-\



  • To chronicle my idiocy and for your info for later hoba, make sure to tell people not to have NAT Reflection disabled. Lol, I unchecked the box to disable it and boom it worked. Thanks for your patience.



  • Ah, you were testing from inside!  :o That makes sense now. Thanks for letting us know. It would have worked fine from the outside though  ;)



  • Yeah, apparently. Actually if some sort of plain text explanation could be added to that option that would be awesome.


Locked