Help to install HAVP



  • hi,
    Please i want help.
    i installed pfsense 2.0, and use it to load balance between 2 adsl lines, and it work good, i dont install any packages.
    now i need to install HAVP packages,
    what the steps and config needs to install HAVP?
    note: i use pfsense to load balance between 2 adsl lines with out install any packages.
    regards



  • Look GUI menu System>Packages
    You must have pfSense HDD installation.



  • ok, after that, what is the config of HAVP to work?
    thnx



  • @nassman:

    ok, after that, what is the config of HAVP to work?
    thnx

    Antivirus settings

    Update DB (take 5-15 min)

    General page

    Check Database version
    Check Clamd service state (running)

    Proxy Settings

    Enable
    Set proxy settings (mode/iface/port)
    Set other proxy settions
    Save

    General page

    Look services state.



  • thanks
    can you give me the best setting HAVP to work with load balance?.
    proxy settings (mode/iface/port).
    regrads



  • About loadbalansing - can't
    Proxy settings set how you need. Example - transparent/LAN/3125



  • i mean that i use pfsense to load balance between to adsl lines
    if i use transparent/LAN/3125 that will work well and not happen and problem.
    and deny virus from and to my network
    thanks



  • @nassman:

    i mean that i use pfsense to load balance between to adsl lines
    if i use transparent/LAN/3125 that will work well and not happen and problem.
    and deny virus from and to my network
    thanks

    I mean what can't say nothing - i not tested this configuration.
    In theory all must work.

    You can answer to question if test this.



  • i install HAVP, please show this:


    Installation of HAVP antivirus completed.
    Beginning package installation for HAVP antivirus…Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading HAVP antivirus and its dependencies... Checking for package installation...
    havp-0.91_1  (extracting)
      libltdl-2.2.10  (extracting)
      unzoo-4.4_2  (extracting)
      lha-1.14i_6  (extracting)
      arj-3.10.22_4  (extracting)
      arc-5.21o_1  (extracting)
      clamav-0.96.3_2  (extracting)
      libltdl-2.2.10
      unzoo-4.4_2
      lha-1.14i_6
      arj-3.10.22_4
      arc-5.21o_1 done.
    Loading package configuration... done.
    Configuring package components...
    Additional files... done.
    Loading package instructions...
    Menu items... done.
    Integrated Tab items... done.
    Services... done.
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Writing configuration... done.
    Starting service.

    Installation completed.
    HAVP antivirus setup instructions:
    Please check the HAVP settings.


    now when i open staus > system log
    i got this:


    Nov 20 08:12:57 php: /pkg_mgr_install.php: Beginning package installation for HAVP antivirus.
    Nov 20 08:12:58 check_reload_status: syncing firewall
    Nov 20 08:13:54 php: /pkg_mgr_install.php: The command '/usr/local/etc/rc.d/havp' returned exit code '1', the output was 'Usage: /usr/local/etc/rc.d/havp fast|force|one'
    Nov 20 08:13:54 php: /pkg_mgr_install.php: The command '/usr/local/etc/rc.d/clamd.sh' returned exit code '127', the output was '/usr/local/etc/rc.d/clamd.sh: not found'
    Nov 20 08:13:55 check_reload_status: syncing firewall
    Nov 20 08:13:55 php: /pkg_mgr_install.php: Stopping HAVP
    Nov 20 08:13:55 check_reload_status: syncing firewall
    Nov 20 08:13:56 check_reload_status: reloading filter
    Nov 20 08:13:56 check_reload_status: syncing firewall
    Nov 20 08:13:57 php: : The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:18: syntax error'
    Nov 20 08:13:57 php: : There was an error while parsing the package filter rules for /usr/local/pkg/havp.inc.
    Nov 20 08:13:59 check_reload_status: reloading filter
    Nov 20 08:14:00 php: : The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:18: syntax error'
    Nov 20 08:14:00 php: : There was an error while parsing the package filter rules for /usr/local/pkg/havp.inc.
    Nov 20 08:14:01 check_reload_status: syncing firewall
    *********************************************************88

    what the wrong, are there any error or problem?
    thanks



  • Pls show you /usr/local/pkg list files.



  • $ ls /usr/local/pkg
    carp.xml
    carp_settings.xml
    havp.inc
    havp.xml
    havp_avset.xml
    miniupnpd.inc
    miniupnpd.xml
    olsrd.xml
    openntpd.inc
    openntpd.xml
    parse_config
    pf
    routed.inc
    routed.xml
    sasyncd.xml



  • OK. Thanks.
    I need time for ext testing rules in 2.0.



  • tyt



  • hi, i install havp and now work fine with load balance, if i select standard or internal mode, the load balance work fine.
    but if select transparent mode, only one line work.
    thank you dvserg
    Regards



  • Firewall Rule fixed for 2.0
    Need reinstall havp and check transparent mode new.



  • hi,
    i use 2.0-BETA4  (i386) built on Fri Nov 19 13:56:23 EST 2010, are you want to update it to last update version, then reinstall HAVP, or want to reinstall HAVP with out update 2.0
    thanks



  • @dvserg:

    Firewall Rule fixed for 2.0
    Need reinstall havp and check transparent mode new.

    I mean need full reinstall of the HAVP.



  • I reinstall havp and check transparent mode, the same before, when select transparent, the load balance to work, only work woth standard or internal
    thanks



  • hi all,
            I made a complete reinstall of havp.The installation for HAVP from shell was a success, it didn't gave any errors. But when i executed freshclam it gave the following error :

    /libexec/ld-elf.so.1:Shared object "libbz2.so.4" not found, required by "freshclam"

    what should i do now ? Also how to start havp from shell ? Because i installed havp from the shell itself it is not listed in the Web GUI installed packages.

    Thanks in advance.
    NM04


Log in to reply