2 Wans with different providers, different speeds, goes only via slow.. [SOLVED]



  • Hello,

    I have successfully configured dual wan on pfSense for 2 x DSL from SAME provider with SAME up/down link speeds. www.speedtest.net shows double speeds.
    Now I'm testing same way for 2 x wifi networks with DIFFERENT providers:

    • both providers have assigned IPs from RFC 1918 networks:
      10.10.x.x - ISP1
      192.168.1.x - ISP2
    • both have DIFFERENT gateways and DNS servers
      10.10.x.x - ISP1 GW
      192.168.1.1 - ISP2 GW
    • both have DIFFERENT up/down link speeds
      512/256 - ISP1
      1024/254 - ISP2

    Now, I connected single box to pfSense. When testing speeds, only SLOWER link is used (not both at same time, even if I open multiple websites, connections…). I don't know if it depends on "TIER" setting, but tried different combinations (1/1, 1/2, 2/1) without success.
    Even if I manually set DEFAULT GW to ISP2 pfSense still uses slower link of ISP1.

    I disabled options:

    • Block private networks
    • Block bogon networks
      for all interfaces.

    ISP2 is on OPT1 iface.









  • I'm not sure, if I'm right with what you mean, but remember:

    If you have WAN1 with 2MBit/s and WAN2 with 3MBit/s and you are starting one download, you do NOT have 2MBit/s + 3MBit/s = 5MBit/s
    LoadBalancing can not double your download speed, it only could double your bandwidth.

    With LoadBalancing (pfSense uses Round Robin) you can start in the example above one download with 3MBit/s and a second one with 2MBit/s.

    Further, have you tried, if both WAN connections were used? You can do this by refrshing this site multiple times:
    http://www.pfsense.org/ip.php



  • Ok thanks, that cleared my mind ;) Yes, IP is changing.
    I was wondering why can summarize speeds when using 2 DSL for single download and cannot for different ISPs..


Log in to reply