Traffic Shaper applied, packets get blocked



  • Hi there,

    I am really eager to try and understand the shaper in 2.0. I have a really fast VDSL connection with 50/10Mbit/s and from real live tests I can tell you that I get around 6Mbyte/s download and about 1Mbyte/s upload speed. Still, if I watch NBA basketball via League Pass the video sometimes stutters when I set the bandwidth on the video screen to 3000Kbps which is not much compared to my available speed.

    I have one internet connection and two LAN interfaces (LAN and WLAN). My ruleset exists for both LAN and WLAN and is working correctly. Now when I just use the shaper wizard for Multiple Lan/Wan a lot of packages get blocked by the default deny rule when I take a look at the logs which is weird. I see lots of port 80/443 get blocked and also my IMAPS port 993 although the rules are there to allow that traffic. If I remove the shaper again I can surf the internet fine again with my iPhone on WLAN for example.

    Is there still really no good guide out there on how to properly configure the shaper in 2.0? Has anyone gotten this to work? I want to prioritize my HTTP(S) traffic so that all other traffic gets lowered down when I surf. If I do not need this traffic it should get used by other stuff…

    Also, isn't it possible to just use the floating rules when I want to have the same rules applied to LAN and WLAN? So that I do not need to enter rules twice?

    How much of my bandwidth should I enter into the wizard?

    Any advice? Thanks for your time and help...



  • Add a subnet alias for both of your LAN subnets.

    Use that alias in the firewall rules and you won't need to create a duplicate for each rule.

    As for the traffic shaper, you will need to figure it out on your own since every setup is unique.  For starters, since you do know that your connection is capable of 48/ 8 in reality, you can just use those numbers.

    The default queue values generated by the wizard needs to be heavily adjusted to suit your requirements though.



  • Anyone else got a info on how to make videos like NBA live streaming work flawlessly?



  • Tried again to set up the shaper. I can communicate via my LAN interface but everything on WLAN is not getting any connection. I can't surf via iPhone, but I can browse the app store via iPhone…

    Weird. Nothing gets blocked now if I have a look at the pflog0...

    Any ideas?



  • I am sorry no conclusive information here.
    Its just your claims.
    /status.php output if you need real help and not second guessing.



  • Thanks for your help, ermal. I will send you the status page via mail…

    When I activate the shaper the way I configure it, the internet on LAN gets very slow. On WLAN it is more than slow. Sometimes a can open a page like apple.com but it never fully loads. Also other apps on my iPhone get no internet connection at all...

    Thanks for looking at the status page...



  • Hi ermal,

    did you check the file I emailed you? Any news on the topic?

    Thanks



  • Still having this problem with the newest snap. My WLAN devices can resolve ip addresses via dns but I can't access websites or anything else when the shaper is enabled. tcpdump shows me that packets flow through my wireless interface though…

    Any help?



  • Any new info here? I think this also should be fixed if we want a RC soon…


Locked