Can't uninstall/install squid



  • Trying to uninstall my broken squid…:

    Removing package... 
    Loading package configuration squid.xml... 
    Loading package instructions...
    
    

    Then at the very bottom of the page it goes:

    
    Warning: delete_package(/usr/local/pkg/squid.inc): failed to open stream: No such file or directory in /etc/inc/pkg-utils.inc on line 754 Fatal error: delete_package(): Failed opening required '/usr/local/pkg/squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/inc/pkg-utils.inc on line 754
    

    Any ideas?



  • heres what I do:
    install squid 3
    uninstall squid
    uninstall squid 3
    install squid (if upgrading)

    that fixes my issue



  • Squid3 is also fucked… :?

    EDIT: Fixed, just go to /usr/local/pkg and delete squid.xml
    Then go to the pfsense uninstall package, and wallah.



  • FYI, I had this problem too. Turns out that you must remove lightsquid before attempting to remove squid, or you'll run into this problem.


Locked