VirtualBox - Clock



  • I'm running the latest 2.0 Beta snapshot on Sun VirtualBox.

    Everything works but the clock is only correct after boot.
    After a few hours it is completly ofset -4 a -6h

    I tried setting the Hardware clock in UTC time in VirtualBox option. But this does not help.

    I'm also running Pfsense in a VMWare server and it works there so it must be because of the VMTools that are in installed.

    Does somebody know how to fix this clock thing in VirtualBox ? or install the virtualbox guest additions for pfsense ?



  • This is not an issue specific to PFSense. Time drift on VirtualBox clients has been a problem for a while. Most people that encounter this disable it on the host and just point the client to a proper NTP server.



  • In System: Advanced: System Tunables, try setting kern.timecounter.hardware to i8254



  • what offhand does that do?  i just checked my virtual pfsense and it is several minutes behind the host :(  i guess i can just turn ntp on if all else fails?



  • @Efonne:

    In System: Advanced: System Tunables, try setting kern.timecounter.hardware to i8254

    Did not help.  clock still runs slow.

    Is there a way to force the ntp client to sync the clock every 30m ?


Log in to reply