OSPF Bridging



  • I have a LAN and OPT1 interface that is bridged. I am having trouble getting it to work with the OPT1 interface that every time I add the interface the service no longer runs or start. I presume this is because that interface has no IP. Is there a way to work around this problem?

    I am on v2.0 beta 4

    On another note it would be nice if it exchanged VPN sites as well.



  • OSPF is a routing protocol that in it's simplest form exchanges routes with other routers running OSPF that are defined as being in the same area. It uses the IP address of the interface for things like elections with other routers (highest IP wins) so you can't add an interface to an area unless it has an IP address.

    Not sure what you mean by "Would be nice if it exchanged VPN sites" OpenOSPFD can be configured to replicate the kernel routing tables and statically configured routes so it will share VPN routes. If you mean that you want to use tun interfaces then that is a no go as OpenVPN creates them dynamically and AFAIK PFSense has no way of having them display on the interface drop down. However there is nothing stopping you adding a router at the remote site to your OSPF area if you have enough bandwidth down the tunnel.



  • I would of expected that in bridge mode it would pass it through like a switch.



  • Bridging is done at layer 2 OSPF is a layer 3 protocol. So a bridged interface will pass the traffic but must not be added to the OSPF area which is what I assume you have done

    snip/

    I am having trouble getting it to work with the OPT1 interface that every time I add the interface the service no longer runs or start.

    /snip

    If what you are saying is that by simple bridging the interface OSPF fails then that shouldn't happen.
    Can you post the config that loads and the one that fails if this is the case.



  • I told OSPF to use then LAN port but the OSPF traffic didn't show up on the other server. I have moved away from that setup now anyway as it was causing me other problems.

    Should this package work with talking to pf v2 and v1.2.3 as when I got it working traffic wouldn't flow between the 2 nic's.


Log in to reply