No Default Gateway in Routing Table (solved)



  • Hi,

    I have just installed and configured pfSense 1.2.3 on a new router. When I went to test it, I noticed that it couldn't get on the internet, despite configuring a WAN interface, ensuring cables are connected, etc.

    When I checked the page "Diagnostics…Routes", I noticed that there is no route for the default gateway in the routing table.

    If I reset the router to factory default configuration, I do get a default gateway in the routing table, but I lose all of the other settings I configured.

    What could be causing the default gateway route to not appear in the routing table? What have I done wrong?  :-[



  • Doh! I solved my own problem. It was totally a "layer 8" issue. For some reason, I stupidly set the netmask on the WAN connection to 32 bits! Setting it to the correct value (in this case, 26) fixed the problem and gave me back a default gateway in the routing table. I hope that helps some other fool like me.  :)


Log in to reply