OpenVPN Tunnel Settings Full vs Nano



  • I have a couple of boxes running the latest 2b4 snapshot Nov29.  One is Nano the other is Full.

    I just noticed that under the Tunnel Setup section (Remote access SSL/TLS + User Auth) there is a box for Local Network on the Full version that does not exist on the Nano version.

    Both tunnels seem to work fine BTW.

    Is this an omission in the GUI or by design?  If by design what is the difference?


  • Rebel Alliance Developer Netgate

    I have a fresh nanobsd install on an alix and a VM with a full install and they both show identical options on the OpenVPN server setup.

    Are you sure you are looking at the same page on both routers?



  • I just went back and checked.  It was not there on the Nano so I decided to toggle from P2P back to Remote access SSL/TLS + User Auth and save the config again.  Seems to be fine now.

    I used the wizard to setup both boxes.  Not sure why that did not populate initially on the Nano.



  • Well I thought it was good.  Just looked again and it's gone.  If I toggle to something else P2P etc and back to Remote it is there. I hit save the go back it is gone. Thought it might be browser specific. Tried IE, Firefox, and Chrome all with identical results.

    See attachments.

    ![Capture11-30-2010-9.32.02 PM.png](/public/imported_attachments/1/Capture11-30-2010-9.32.02 PM.png)
    ![Capture11-30-2010-9.32.02 PM.png_thumb](/public/imported_attachments/1/Capture11-30-2010-9.32.02 PM.png_thumb)
    ![Capture11-30-2010-9.38.35 PM.png](/public/imported_attachments/1/Capture11-30-2010-9.38.35 PM.png)
    ![Capture11-30-2010-9.38.35 PM.png_thumb](/public/imported_attachments/1/Capture11-30-2010-9.38.35 PM.png_thumb)



  • That must be a bug in the code that hides it.  When you have "Force all client generated traffic through the tunnel." checked, the Local Network box is meaningless, since the route that the checkbox setting pushes to the client would cover anything you could put in the Local Network box.


  • Rebel Alliance Developer Netgate

    @Efonne:

    That must be a bug in the code that hides it.  When you have "Force all client generated traffic through the tunnel." checked, the Local Network box is meaningless, since the route that the checkbox setting pushes to the client would cover anything you could put in the Local Network box.

    It's not just an issue there really, upon further examination.

    I just committed a change that will rerun the javascript (gwredir_change()) that shows and hides that box on every server mode change. I also noticed that the gateway redirect box was not being hidden when switching to shared key mode, it should be correctly disabled now.


Log in to reply