Squid CacheMgmt



  • Hello!

    Don't know if this is a normal problem, but i searched and I didn't find anything about it.

    When I made some change in Services -> proxy server -> Cache mgmt press save, the page reloads and don't show any of my changes.

    I'm trying to put Hard disk cache size to 0 (Zero) because I don't want anything to be cached. I just want to be able to block some url. If there's some other way to do it, I appreciate the tip :-)

    In the config.xml file, I can see the changes that I have done, but I can also see all the others. It seems that the new configuration is being appended, but the old one is not removed.

    Thanks.

    Best Regards.



  • Try setting the 'hard disk cache system' to 'null' on the same GUI page.  This is exactly what the null option is for.  That said, I don't use it so I can't be sure that it works.



  • Hi!

    Well… i can do that:

    Hard disk cache location -> null

    But when I press save this revert to /var/squid/cache

    I added the option
    enable-storeio=null
    to Custom Options in General tab

    Don't know if it's the right thing to do! :-P

    Thanks


  • Rebel Alliance Developer Netgate

    Sounds like you have an issue in your config file. Make a backup, edit out the <config>tags and multiple settings from inside of <squidcache>and then restore the backup.</squidcache></config>



  • I believe you need to remove your 'custom option'.  This field should be left blank.  At the top of the page on the Cache Management tab, set 'Hard Disk Cache System' to null.  The cache location should not matter as no storage will actually be used.


Log in to reply